Question

FreeRadius is not sending attributes to the Wireless Controller on the Access-Accept package


We have configured a FreeRadius to work along with an IdentiFi Wireless Controller, but even when it is authenticating correctly, the FreeRadius server it's not sending the attributes on the Access-Accept package. We are trying to send specifically the Filter-Id attribute in order to have one single SSID and send the users to their respective VLAN or Topology matching the Roles with the Filter-Id.

When doing a packet capture from the controller, we see that none attribute is sent from the FreeRadius server to the Controller on the Access-Accept message, therefore the users are note getting redirected to the right Role and Topology.

Seems that the issue might be on the FreeRadius server but we haven't figured how to solve it.

We would appreciate any comment you may have.

Thank you.

4 replies

Userlevel 7
You have to edit the user's file under the group of users or the specific user to include the filter-id

Filter-Id = "Role on controller" ### this is case sensitive
Doug wrote:

You have to edit the user's file under the group of users or the specific user to include the filter-id

Filter-Id = "Role on controller" ### this is case sensitive

Hello Doug,

Thank you for your reply, even though I have already tried that but with no luck. It seems that I must do something with the file "default" on the "post-auth" section for it to send the attributes I am defining for the users, included the Filter-Id.
Userlevel 7
Doug wrote:

You have to edit the user's file under the group of users or the specific user to include the filter-id

Filter-Id = "Role on controller" ### this is case sensitive

I'm not sure about any default setting I needed to change the last time I had this working. I couldn't find anything in any of our databases either.
Doug wrote:

You have to edit the user's file under the group of users or the specific user to include the filter-id

Filter-Id = "Role on controller" ### this is case sensitive

Hi Manuel,

Did you get the filter-id in Radius-Accept packet working? Thanks!

Reply