ExtremeCloud IQ- Site Engine & Extreme Management Center

 Can I enforce an Avaya ERS3600 into NAC demokit? see screenshot that this is not possible.

Jump to Best Answer
Sacha Brys's profile image
Sacha Brys posted 10-24-2019 14:14

 

Zdeněk Pala's profile image
Zdeněk Pala

The ERS does not support radius configuration through SNMP.

To configure ERS with NAC we recommend to use ERS NAC Enforce scritp from Github.

Regards

Sacha Brys's profile image
Sacha Brys

Hi thanks for the info you gave. Allthough I’m totally new in this ;-)

I tried the script (Python)
https://raw.githubusercontent.com/extremenetworks/ExtremeScripting/master/Netsight/oneview_CLI_scripts/xml/BOSS_NAC_Enforce.xml

but from the beginning I got the message:
Date and Time: 2019-10-25T02:51:08.796
EMC User: root
EMC User Domain: 
IP: 192.168.10.222
SyntaxError: ("no viable alternative at character '?'", ('<string>', 1, 1, '<?xml version="1.0" encoding="UTF-8" standalone="yes"?>\n'))
What is going wrong

thanks again

Zdeněk Pala's profile image
Zdeněk Pala

Hi.

Please check if your procedure is correct:

  • Download the XML file (the link is correct)
  • Import the script:
    • XMC version 8.0 = In the Extreme Management Center -> Administration -> Scripting -> Import…
    • XMC version 8.1.2 and newer = Import the sctript = In the Extreme Management Center -> Tasks -> Scrips -> Import

 

 

Sacha Brys's profile image
Sacha Brys

Hi, sorry for the delay, I did follow the procedure.

But I always get the error:
SyntaxError: ("mismatched input ';' expecting COLON", ('<string>', 22, 24, '    if len(sys.argv) &gt; 1: # Json file as 1st argv\n'))

 

thanks in advance

Zdeněk Pala's profile image
Zdeněk Pala

Hi,

strange. I just tested and I did not get any error. it worked for me. Can you please be more descriptive about what you did?

 

What is your XMC version? Was your XMC deployed as VM or as Exe or bin? 

Sacha Brys's profile image
Sacha Brys

Hi,

The version of XMC is: netsight_appliance_64bit.8.2.3.67-Small.

It was deployed as a VM.
I added the ERS 3600 into XMC first, so, it can communicate over snmpv3.
But when I want to run this script against it, I got this message as I described.

Thanks in advance.
 

Zdeněk Pala's profile image
Zdeněk Pala

Hi.

I believe the issue is:

We added the proper “HTML/XML” encoding later to the XMC. the &gt; is not translated during the import and not recognized during the execution

The option 1 for you:

  • replace &gt; with >
  • replace &lt; with <

Option 2 for you:

  • download attached TXT
  • edit your script and paste the content of the TXT file
  • save

Good luck!

Sacha Brys's profile image
Sacha Brys

Many thanks