ExtremeSwitching (EXOS)

 View Only

 EXOS VM 22.7 and above

Piotr Wilczak's profile image
Piotr Wilczak posted 01-28-2022 19:06
Hi All 
I am relatively new to virtualisation so it could be I am missing something .  
I am running GNS3 VM (ver 2.2.28) on Virual Box  (Version 6.1.30 r148432 (Qt5.6.3). 
I have allocated 4 CPU cores and 8192 RAM for this VM . The OS is MAC OS Monterey version 12.1
Now,  I have loaded couple of EXOS VM using appliance template provided on GitHub 

https://github.com/extremenetworks/Virtual_EXOS/blob/master/GNS3_EXOS-VM_Guide_macOS.md
All the older version of EXOS VM are working very well however I have issue booting up 22.7 and above 
When I start any of the EXOS 22.7 and above the CPU for the GNS3 VM goes to around 25% but soon after drops down to around 0.5  To me it looks like the switch starts booting but than it stops . If I click on Console it will open but this is all I get on the console screen (even if I wait for 30 minutes or so ) 
  Booting `Primary OS Image on (hd0,1) using VGA console' Booting `Primary OS Image on (hd0,1) using VGA console
Than if I close console and reopen while the switch appliance is still running I get the below and nothing else : 
sh-3.2$ PATH='/Applications/GNS3.app/Contents/MacOS:/usr/bin:/bin:/usr/sbin:/sbin' exec telnet 192.168.56.103 5006
Trying 192.168.56.103...
Connected to 192.168.56.103.
Escape character is '^]’.
From the GNS3 VM server logs I could not see any differences between working and not working version during the boot time ( Please see attached ) 
I have tried increasing the RAM allocation for the problematic version but this did not help 
Is there anything that need to changed in the Qemu VMs settings when running 22.7 and above ? 
PS . I have tried the same running the GNS3 VM in Fusion Pro and it was the same behaviour 
Did anyone experienced the same issue in the past ?
Any advise will be much appreciated 
BR 
Piotr