ExtremeSwitching (EXOS)

  • 1.  Switch is getting hang

    Posted 05-15-2014 03:57
    Hi I have a stack of 450e switches which is getting hang and also if save the configuration it takes lots of time. i need suggestion on this to solve the issue


  • 2.  RE: Switch is getting hang

    Posted 05-15-2014 04:35
    Hello,

    There are too many questions and area's that we can look at to determine what is the root cause.

    I suggest that you contact the Extreme TAC.

    Regards
    Ron


  • 3.  RE: Switch is getting hang

    Posted 05-15-2014 08:48
    Anubhav Assuming that the config is corrupt you can log into the bootrom of the switch and load a different config or default . To get into the bootrom hold down the space bar and reboot the switch. Continue to hold down the space bar and you will get the bootstrap. Type boot and continue to hold the space bar and you will then get into the bootrom. To load default type in config none then reboot the switch. I do agree with Ron calling TAC is a good call with troubleshooting as it will be resolved quicker.


  • 4.  RE: Switch is getting hang

    Posted 05-15-2014 14:17
    What is the TOP command output? which process is going high? When you do save, what process is going high? you open different session and see the process name which continuously utilizing the high CPU. What is the software version running on switch?


  • 5.  RE: Switch is getting hang

    Posted 05-19-2014 04:41
    Hi Sumit i tried the please find the output below:

    Mem: 247004K used, 7660K free, 0K shrd, 17464K buff, 49084K cached
    CPU: 8.5% usr 21.6% sys 0.0% nic 67.2% idle 0.0% io 0.0% irq 2.6% sirq
    Load average: 6.40 5.91 5.85 4/176 1983
    PID PPID USER STAT RSS %MEM CPU %CPU COMMAND
    Mem: 247064K used, 7600K free, 0K shrd, 17464K buff, 49084K cached
    CPU: 11.1% usr 18.0% sys 0.0% nic 66.1% idle 0.0% io 0.0% irq 4.6% sirq
    Load average: 6.37 6.02 5.90 11/176 1985
    PID PPID USER STAT RSS %MEM CPU %CPU COMMAND
    1270 2 root SW 0 0.0 0 6.9 [bcmRX]
    1419 1 root S < 25392 9.9 0 6.2 ./hal
    1442 1 root S 3972 1.5 0 4.9 ./fdb
    1539 1 root S 21384 8.3 0 3.6 ./etmon
    1215 2 root RW< 0 0.0 0 3.2 [bcmLINK.0]
    1480 1 root S 4932 1.9 0 1.6 ./mcmgr
    1421 1 root S 1764 0.6 0 0.9 ./nodemgr
    1985 1984 root R 776 0.3 0 0.9 top -d 3
    1749 1 root S 752 0.2 0 0.9 ./exsshd
    1255 2 root DW< 0 0.0 0 0.9 [tocpd_tx]
    1219 2 root RW< 0 0.0 0 0.9 [bcmLINK.1]
    1518 1 root S 3544 1.3 0 0.3 ./acl
    1431 1 root S 2412 0.9 0 0.3 ./aaa -t random
    1760 1059 root S 1304 0.5 0 0.3 /exos/bin/exsh
    1208 2 root SW< 0 0.0 0 0.3 [bcmCNTR.0]
    1220 2 root SW< 0 0.0 0 0.3 [bcmASYNC]

    Image : ExtremeXOS version 12.5.4.5 v1254b5-patch1-13 by release-manager

    As of now switch is working fine but some time if i type show temperature command then switch shows " command timeout ". Also some PC's not getting the IP directly connected to this switch, if try to save config then process never complete and doted (Saving config ............) line goes so long

    Thanks
    Anubhav



  • 6.  RE: Switch is getting hang

    Posted 05-19-2014 04:54
    Are [bcmRX], HAL and FDB process constantly utilizing the switch CPU?


  • 7.  RE: Switch is getting hang

    Posted 05-19-2014 05:12
    Hi so any suggestion on this.....


  • 8.  RE: Switch is getting hang

    Posted 05-20-2014 03:16
    Please contact TAC to narrow down ASAP.