ExtremeSwitching (EXOS)

  • 1.  USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 04:40
    Hi, all!

    Is any body has a problem - that USB-flash can't mount?
    USB mount normally only after reboot switch. Note: This conversation was created from a reply on: Failed to download image - Error: File could not be unwrapped.


  • 2.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 12:20
    Hi Alexandr,
    If you can give me some more information, I'll check it out in the lab.
    What model switch are you using?
    File system of the USB drive?
    EXOS Version?

    -Drew


  • 3.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 12:20
    Hi, Drew!

    Trying X460 switches.
    NTFS, FAT
    Different EXOS versions.

    Main problem that USB can mount 5 times, but 6 time - not.
    There is no possibility to "catch" this problem.

    Thank you!


  • 4.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 12:20
    Thanks, I'll ask someone on our lab team to check it out.


  • 5.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 12:20
    Hi Alexandr, We tested this in 15.3 and 15.7 on an X460 with a FAT32 formatted drive. The flash drive was inserted and removed 5-10 times and we were consistently able to
    code:
    ls memorycard
    without any problems on each attempt. I'm not sure what we may be doing differently. If you come up with something, let me know! We'll test and see if we can get it figured out.


  • 6.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 12:20
    Hi, Drew!

    First of all - thanks for help!!!

    I can't "catch" this problem.
    May be main reason - that USB-flash-drive was in NTFS format?!?!?!

    Thank you!


  • 7.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-08-2015 13:04
    HI,

    I used USB to upgrade some X460, X670 and X770. I used a Sandisk USB (4GB) in fat 32.

    You can use the command:
    ls /usr/local/ext
    to see the file on the USB.

    I don't need to restart the switch to see the USB KEY.

    Emmanuel



  • 8.  RE: USB drive doesn't mount until switch is rebooted

    Posted 04-13-2015 10:27
    I have seen this issue when you update from say version 12.x to 15.x - turned out in our case if you look at the flash drives that we used they did not actually have a partition (believe it or not) created and the only way we could tell is if we used disk utility on the mac. There have been a few times where the mfg of the stick seems to make a big difference as well. If you delete and re-add partition using disk manger it has solved it for me 100% of the time.