ExtremeSwitching (EXOS)

Expand all | Collapse all

SFP (SX Media) not activating on 15.7.1.4

Tino

Tino04-08-2015 11:15

Stephane Grosjean

Stephane Grosjean04-13-2015 08:26

Tino

Tino04-13-2015 08:31

  • 1.  SFP (SX Media) not activating on 15.7.1.4

    Posted 04-07-2015 18:55
    On a X460G2-48p-GE4 the SFP ports wont activate after I upgraded the firmware from 15.6.2.12 to 15.7.1.4

    If I downgrade to 15.6.2.12 the port starts up again and the uplink connects to the core switch.

    I checked the release notes and cannot find any info, on the logs it when I pull the sfp out and put it back in it just shows:

    04/07/2015 14:42:14.33 : Media SX is inserted into Port 49

    The SFP's were bought from Enterasys and used on C5 switches. The make on the SFP's are JDSU (JSP-12S0AA1) PN 52P6529


  • 2.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-07-2015 19:10
    Tino,

    There shouldn't be any issues but obviously there is... can you run the following command for both versions to me?

    debug hal show optic port

    Thanks,

    Bill


  • 3.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-07-2015 19:51
    Thank you for the reply Bill,
    Primary ver: 15.7.1.4

    Output:

    X460G2-48p-G4.1 # show ports 49 no-refresh
    Port Summary
    Port Display VLAN Name Port Link Speed Duplex
    # String (or # VLANs) State State Actual Actual
    ==================================================================
    49 Default E R
    ==================================================================
    Port State: D-Disabled, E-Enabled
    Link State: A-Active, R-Ready, NP-Port not present, L-Loopback,
    D-ELSM enabled but not up
    d-Ethernet OAM enabled but not up

    X460G2-48p-G4.2 # debug hal show optic port 49
    Port 49
    SFP or SFP+: SFP
    Signal: present
    TX Fault: no
    SFP/SFP+ Vendor: JDS UNIPHASE
    SFP/SFP+ Part Number: JSP-12S0AA1
    SFP/SFP+ Serial Number: F71443470699
    SFP/SFP+ Manufacture Date: 07040901
    SFP/SFP+ Type: SFP/SFP+
    Connector: LC
    GE Compliance: 1000BASE-SX
    Wavelength: 0

    Working output:

    Secondary ver: 15.6.2.12
    patch1-1

    X460G2-48p-G4.1 # show ports 49 no-refresh
    Port Summary
    Port Display VLAN Name Port Link Speed Duplex
    # String (or # VLANs) State State Actual Actual
    ==================================================================
    49 Default E A 1000 FULL
    ==================================================================
    Port State: D-Disabled, E-Enabled
    Link State: A-Active, R-Ready, NP-Port not present, L-Loopback,
    D-ELSM enabled but not up
    d-Ethernet OAM enabled but not up

    X460G2-48p-G4.2 # debug hal show optic port 49
    Port 49
    SFP or SFP+: SFP
    Signal: present
    TX Fault: no
    SFP/SFP+ Vendor: JDS UNIPHASE
    SFP/SFP+ Part Number: JSP-12S0AA1
    SFP/SFP+ Serial Number: F71443470699
    SFP/SFP+ Manufacture Date: 07040901
    SFP/SFP+ Type: SFP/SFP+
    Connector: LC
    GE Compliance: 1000BASE-SX
    Wavelength: 0


  • 4.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-07-2015 21:49
    Tino,

    Thank you for giving me the information. I am going to open a case (unless you already have one open) and have this escalated, as soon as I do I will send you the case# for your reference. I am sorry for the inconvenience!

    Bill


  • 5.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-08-2015 03:32
    I have opened a case yesterday, Case Number: 01112891

    Thank you,


  • 6.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-08-2015 11:08
    Thanks, TAC has confirmed the issue and is working with engineering. Stay tuned...


  • 7.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-08-2015 11:15
    Thank you Bill


  • 8.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-09-2015 18:49
    I opened a case on this issue on 3/16/2015. It was escalated on 4/7/2015. I have not heard anything since the case was updated. I'm glad more people are opening tickets on this.

    Firmware seems to work fine on the 1st gen X460-48t

    Also, on the 24 port x460G2 , optics seem to work on ports 21-28, but they do not work on ports 29-32.


  • 9.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-13-2015 06:02
    I thought i was going crazy! anyways fingers crossed, hopefully we will hear something back soon.


  • 10.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-13-2015 08:26
    Hi,
    did you try to reboot once in 15.7?


  • 11.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-13-2015 08:31
    Yes multiple times.


  • 12.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-13-2015 08:37
    Toño, I will be in TAC this afternoon and will give you an update. I am sorry for the delay. Bill


  • 13.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 04-13-2015 13:31
    Tino,

    I have been looking into the issue with the 1000BASE-SX and 10/100/1000BASE-T SFPs in the Summit X460G2. Thus far in our testing the issue has only been seen when running 15.7.1.4. Engineering has been made aware of the issue.

    Andrew


  • 14.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 05-14-2015 12:34
    Today I tested a Extreme 1000BASE-SX SFP (10051H) and that does not work either on 15.7.1.4

    X460-G2-48p-GE4 no SFP's work on 15.7.1.4

    X460-G2-48p-10GE all SFP's work on 15.7.1.4

    The problem seems to be limited to X460-G2-48p-GE4 on 15.7.1.4



  • 15.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 05-14-2015 12:35
    X460G2-48p-G4.2 # debug hal show optic-info port 49 Port 49

    SFP or SFP+: SFP

    Signal: present

    TX Fault: no

    SFP/SFP+ Vendor: WTD

    SFP/SFP+ Part Number: RTXM191-552

    SFP/SFP+ Serial Number: BP145100790163

    SFP/SFP+ Manufacture Date: 141219

    SFP/SFP+ Type: SFP/SFP+

    Connector: LC

    GE Compliance: 1000BASE-SX

    Wavelength: 850



    GBIC supports DDMI. MonitorType: 68



    X460G2-48p-G4.3 # show port 49

    Port Summary Monitor Thu May 14 12:06:13 2015

    Port Display VLAN Name Port Link Speed Duplex

    # String (or # VLANs) State State Actual Actual

    ==================================================================

    49 Default E R



  • 16.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 05-14-2015 12:39
    Tino,

    Yes, the behavior thus far in our testing indicates the unexpected behavior is particular to EXOS 15.7. CR xos0061283 has been assigned to the issue. The software fix is currently scoped for EXOS 15.7.3.

    -Andrew



  • 17.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 05-14-2015 12:42
    Thank you very much Andrew. That has been extremely helpful. GTAC told me my SFP's were not supported.


  • 18.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 07-09-2015 13:21
    This issue does not seem to occur in 16.1.1.4. In 16.1.1.4 the SFP ports come up with no problems.


  • 19.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 07-09-2015 13:21
    Hi Tino,
    I see the fix made it into 16.1 under another CR number (xos0060179). That explains why you see it working there.
    Also, I noticed an update to the CR Andrew mentioned (xos0061283) - The fix is now expected be included in 15.7.2.


  • 20.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 07-09-2015 13:21
    This v15.7.1 issue is being tracked in GTAC Knowledge article
    No Ethernet Link on last four 1G SFP ports of Summit X460-G2 running EXOS v15.7.1.
    The estimated release date for the v15.7.2 fix is now July 22 2015.


  • 21.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 07-15-2015 20:32
    This issue is resolved in EXOS 15.7.2+ and EXOS 16.1+ releases. Both are available from the support site.

    For more information about the problem, please have a look at this article on GTAC Knowledge.
    If you need help upgrading, refer to this article: How to Obtain and Upgrade EXOS


  • 22.  RE: SFP (SX Media) not activating on 15.7.1.4

    Posted 07-17-2015 08:44
    Excellent! Thank you very much for all your help.