ExtremeSwitching (EXOS)

Expand all | Collapse all

Ping to the internet from virtual exos doesn't work

Michal Rz

Michal Rz06-28-2016 10:34

Ala Eddine Chhima

Ala Eddine Chhima06-28-2016 10:34

  • 1.  Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 09:57
    Hi,

    I am new user of Extreme products, so i installed EXOS for virtual lab but when i did all the configuration (vlan, ipaddress, port) , i couldn't ping any website or server in the internet , i can't even ping my default gateway .So, can someone help me to resolve this problem?

    Thank you


  • 2.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    did you configure the default gateway?

    configure iproute add default [i]


  • 3.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    i did the configuration of default gateway but it still not responding



  • 4.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    Can you please confirm if the vlan is up (port link-up)? show iproute command will show if the route is up.

    You have also to make sure you mapped the right interface into the VBOX or VMWare.


  • 5.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    It looks like you're using a VM. What are you using, vbox, vmware (workstation or esxi)? what do you see when you run the command show ports no-refresh?


  • 6.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    I am using vbox. and here the result of the command



  • 7.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    can you also send the output to the configs that henrique requested?


  • 8.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13




  • 9.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    Is 192.168.1.254 directly connected to vlan "default" port 1? What's that device connected to port 1?

    If that device is not a FW and would respond to ICMP requests, I believe the issue is related to VBOX port map.


  • 10.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:13
    no i want access internet via wireless network


  • 11.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:34
    try
    ping vr vr-default x.x.x.x


  • 12.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:34
    no it doesn't work



  • 13.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:41
    Hi, please provide more details such as simple topology with IPs and the outputs below:

    show config vlan
    show config rtmgr
    show iproute


  • 14.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 10:41
    I just try to connect the internet from my virtual machine


  • 15.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:32
    Hi,

    What hypervisor are you running this VM in? What does the virtual network config look like in the hypervisor?

    Is the virtual network with 192.168.1.254 on it attached to port 1 on the VM?

    Also, if you have Wireshark installed, can you try taking a packet capture on your PCs adapter that's connected to the virtual network? This way we can see if the traffic is leaving the VM and hitting the vSwitch. (This is assuming that your PC is 192.168.1.254)

    -Brandon


  • 16.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:32
    VirtualBox is the hypervisor,u mean cthe virtual network config by this



    i will try to make a capture of the traffic


  • 17.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:32
    The first adapter in VirtualBox is the management port of the EXOS VM. The "front panel" ports of the VM are the VirtualBox adapters starting at 2.


  • 18.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    If you're not already using it, I'd suggest setting up Bridged Networking for your VM's network setting so that you can assign an IP to the VM that's within the same subnet as your host PC http://www.virtualbox.org/manual/ch06.html


  • 19.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    i did it



  • 20.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    Hi Ala,

    Could you please try configuring your Adapter 2 instead of Adapter 1? I guess that your adapter 1 might be representing the EXOS Mgmt port.

    Also, please share the output below:

    show vlan


  • 21.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44


    here the result of sh vlan


  • 22.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    Your setup connects the EXOS VMs management port (VLAN Mgmt, virtual router VR-Mgmt) to your computers Wi-Fi adapter. If you want to ping using that port, you need to specify the virtual router VR-Mgmt:
    ping vr VR-Mgmt 8.8.8.8[/code]


  • 23.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    Do you mean i should assign the IP 8.8.8.8 to the Mgmt vlan ?


  • 24.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    No, 8.8.8.8 is the well know IP address of Google's primary public DNS server. Thus it is a common IP address for Internet connectivity tests.

    Since you want to reach the Internet, you need to configure an IP address on the Mgmt VLAN, that is allowed to access the Internet from your computer.


  • 25.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44




    i try it


  • 26.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    I am sorry, I forgot to mention that you need to set a default route as well:
    configure iproute add default 192.168.1.1 vr VR-Mgmt [/code]The above assumes that 192.168.1.1 is the default gateway for your network. Please adjust if necessary.


  • 27.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    Thank you Erik, it works 🙂


  • 28.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 12:44
    That's good to read. :-)

    You might be interested in the thread about EXOS Study Guides.


  • 29.  RE: Ping to the internet from virtual exos doesn't work

    Posted 06-28-2016 17:07
    I've updated the title of this topic to note this is for Virtual EXOS.