ExtremeSwitching (EXOS)

  • 1.  Can't reach remote network via tagged port

    Posted 03-13-2016 15:05
    Hi,
    during configuration of my Summit X460 and X440 switches I've encounter a problem with VLAN communication between switches.

    Topology:
    comp1 ==(port23) SW1 (port1)==(port24) SW2 (port1)==(port1) SW3 (port2)== comp2[/code]
    The objective is to communicate between comp1 and comp2 via vlan "v50". Well, there are actually small networks in comp1 and comp2 places, but that's irrelevant in this case. To simplify things I will describe only VLAN "v50" configuration issue, however the same problem exists with other VLANs and VMANs configured on swiches.

    VLAN configuration which works:
    SW1 - X460:
    vlan "v50" ports: 1 tagged, port 23 untagged
    vlan "Default" ports: 1 tagged[/code]
    SW2 - X440:
    vlan "v50" ports: 1 tagged, 24 tagged
    vlan "Default" ports: 1 tagged[/code]
    SW3 - X440:
    vlan "v50" ports: 1 tagged, 2 untagged[/code]
    With above configuration comp1 and comp2 can communicate via VLAN "v50".

    The problem shows up when I remove port 1 on SW1 from VLAN "Default", or remove ports 1,24 on SW2 from VLAN "Default". Comp1 and Comp2 cannot communicate any more (for example no ping). From comp1 I can only reach SW2, further communication is I think not forwarded. What's more even if I disable VLAN "Default" on every switch, but leave ports assignet to it, communication in VLAN "v50" works. Removing ports from VLAN "Default" results in no communication between comp1 and comp2 via "v50".
    STP is disabled on every switch.

    I would be grateful for your help in solving this problem.

    Best regards,
    Krzysztof


  • 2.  RE: Can't reach remote network via tagged port

    Posted 03-13-2016 15:11
    try this:

    on all switches:

    conf vlan default del po all

    on sw1:
    create vlan v50 tag 50
    conf v50 add po 23
    conf v50 add po 1 tag

    on sw2:
    create vlan v50 tag 50
    conf v50 add po 1,24 tag

    on sw3:
    create vlan v50 tag 50
    conf v50 add po 2
    conf v50 add po 1 tag

    This should work

    with EXOS you usually don't use the vlan "default"

    Cheers


  • 3.  RE: Can't reach remote network via tagged port

    Posted 03-13-2016 16:13
    Seems to work. Key was to delete all ports from VLAN "Default" on ALL switches. Not to be cut from SW3 I had to to it in order:
    SW3: conf vlan default del po all
    SW2: conf vlan default del po all
    SW1: conf vlan default del po all

    Thank you very much Andre! Problem SOLVED.