ExtremeSwitching (EXOS)

Expand all | Collapse all

Cisco ios to exos policy based routing

  • 1.  Cisco ios to exos policy based routing

    Posted 05-25-2017 12:03
    Hi all im quite new to Exos and i would like some help migrating from policy based routes from cisco ios to exos...

    my extreme version is 21.1.1.4
    ---------------------------------------------------------------------

    These are the policy i have configured on my cisco

    ip policy route-map RTRMAP-BROCHURELAN-toLB

    ip access-list extended RTRMAP-BROCHURELAN-toLB
    permit tcp host 10.0.202.66 eq www any
    permit tcp host 10.0.202.67 eq www any
    deny ip any any log
    deny ip any any

    route-map RTRMAP-BROCHURELAN-toLB permit 10
    match ip address RTRMAP-BROCHURELAN-toLB
    set ip next-hop 10.0.193.2

    interface Vlan206
    description Staging Brochure
    ip address 10.0.202.65 255.255.255.192 secondary
    ip address 10.0.202.1 255.255.255.192
    ip helper-address 10.0.196.34
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip route-cache policy
    ip policy route-map RTRMAP-BROCHURELAN-toLB
    logging event link-status
    load-interval 30
    snmp ifindex persist
    --------------------------------------------------------------------------------------------------------------



  • 2.  RE: Cisco ios to exos policy based routing

    Posted 05-25-2017 13:01
    https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Convert-a-Cisco-IOS-Access-List-for...

    at the end of this article there is a link to a python script which would convert IOS to EXOS


  • 3.  RE: Cisco ios to exos policy based routing

    Posted 05-29-2017 09:06
    Hi Lutha,

    on EXOS, you can write an ACL (.pol file) that matches on the traffic and then redirects it to a different next-hop. That ACL combines the functionality of both the route-map and the ACL you used on Cisco IOS. That ACL can then be bound to e.g. a VLAN.

    You might want to take a look at the chapter Routing Policies in the EXOS User Guide.

    Thanks,
    Erik