ExtremeSwitching (EXOS)

EXOS Sharing port not in Agg Mbr

  • 1.  EXOS Sharing port not in Agg Mbr

    Posted 12-11-2018 20:05
    Hello Guys in our New Hub !

    Currently I am facing a LACP problem with a single x440-g2 stack in my client's installation.
    The other side of the lag is S-series S4 bonded chassis; I have many other x440-g2 stacks connected to the S4 and configured the same way, which have their lags working good.

    The master sharing port has "Agg Mdr" state of "-" instead of "Y".

    Show sharing output looks like below:

    * Slot-1 PPD22.2 # sh sharing
    Load Sharing Monitor
    Config Current Agg Min Ld Share Dist Ld Share Agg Link Link Up
    Master Master Control Active Algorithm Flags Group Mbr State Transitions
    ================================================================================
    1:26 3:26 LACP 1 L2 A 1:26 - A 3
    L2 3:26 Y A 1
    ================================================================================


    My lag configuration is:

    enable sharing 1:26 grouping 1:26,3:26 algorithm address-based L2 lacp


    Master port 1:26 seems to works fine:

    * Slot-1 PPD22.4 # sh ports 1:26
    Port Summary Monitor Fri Dec 7 11:38:44 2018
    Port Display VLAN Name Port Link Speed Duplex
    # String (or # VLANs) State State Actual Actual
    ========================================================================
    1:26 (0024) E A 10G FULL


    I can see no Rx/Tx errors on this port, but there is almost no Rx on the port.

    Show lacp counters output looks like below (no Rx packets from S4):


    * Slot-1 PPD22.6 # sh lacp counters

    LACP PDUs dropped on non-LACP ports : 0
    LACP Bulk checkpointed msgs sent : 1
    LACP Bulk checkpointed msgs recv : 0
    LACP PDUs checkpointed sent : 144
    LACP PDUs checkpointed recv : 0

    Lag Member Rx Rx Drop Rx Drop Rx Drop Tx Tx
    Group Port Ok PDU Err Not Up Same MAC Sent Ok Xmit Err
    --------------------------------------------------------------------------------
    1:26 1:26 1 0 0 0 1836 0
    3:26 142 0 0 0 389 0

    ================================================================================



    respective config on S4 side is:

    set lacp aadminkey lag.0.16 16
    set port lacp port tg.3.10 aadminkey 16
    set port lacp port tg.3.10 enable
    set port lacp port tg.7.10 aadminkey 16
    set port lacp port tg.7.10 enable


    singleport lag is enabled (globally?):

    set lacp singleportlag enable


    I know that I am not messing up with physical ports - when I disable the 1:26 on EXOS I can see respective S4 port down.

    Any ideas, friends ?
    Robert