ExtremeSwitching (EXOS)

  • 1.  VRRP IPv6

    Posted 09-18-2014 11:51
    Hi folks

    I try to implement VRRP for IPv6.
    Once configured, when I try to enable the instance it says
    XOS : 15.3.2.11
    Device : X450a
    License : Core

    here my config (with fake IPs) :

    #configure my-vlan ipaddress eui64 fe80::/64
    #configure my-vlan ipaddress aaaa:bbbb:cccc:dddd:3002/64
    #create vrrp vlan my-vlan vrid 30
    #configure vrrp vlan my-vlan vrid 30 add virtual-link-local fe80::1

    and here the problem :

    #enable vrrp vlan my-vlan vrid 30
    Error: Failed to enable VR for vlan my-vlan, vrid 30:
    VR must have at least 1 virtual IP address!

    any idea what i'm doing wrong?
    Unfortunately there are no examples in the concept guides.
    fyi i also have a IPv4 vrrp on this vlan with another vrid. this one work lie a charm.



  • 2.  RE: VRRP IPv6

    Posted 09-18-2014 12:09
    Alex,

    I've never set it up with a virt. link-local address. In my setup, I use a 'real' v6 IP
    configure vrrp vlan my-vlan vrid 30 add aaaa:bbbb:cccc:dddd::3456[/code]
    Have you tried that yet, or would that break things?

    Frank (readily admitting that link-local is just a magic black box to me, so I avoid it)



  • 3.  RE: VRRP IPv6

    Posted 09-18-2014 12:09
    That was it.

    I followed the config guide where link-local was on the focus so didn't try that easy test.

    ps : I agree link local is confusing if you're used to IPv4

    Thanks Frank

    Alex