ExtremeSwitching (EXOS)

Expand all | Collapse all

ssh module not loaded, set xmod imag as primary?

  • 1.  ssh module not loaded, set xmod imag as primary?

    Posted 10-18-2017 08:25
    set the image as primary, actually am facing an issue with ssh "module not loaded" after i have checked the switch i found xmod image not set:

    # sh version images
    Card Partition Installation Date Version Name Branch
    ------------------------------------------------------------------------------
    Switch primary Thu Nov 24 12:31:55 UTC 2016 15.5.4.2 nwi-15.5.4.2-4.xos v1554b2-patch1-4
    Switch secondary Thu Nov 24 12:16:32 UTC 2016 15.5.4.2 nwi-15.5.4.2-4.xos v1554b2-patch1-4
    Switch secondary Thu Nov 24 12:17:32 UTC 2016 15.5.4.2 nwi-15.5.4.2-patch1-4-ssh.xmod v1554b2-patch1-4[/code]
    is it possible to set xmod imag as primary?


  • 2.  RE: ssh module not loaded, set xmod imag as primary?

    Posted 10-18-2017 10:51
    Hello Chahid,

    The ssh xmod has to be loaded individually. Since you have the same image on both the primary and secondary you can simply boot into the secondary image and the ssh xmod will load automatically.


  • 3.  RE: ssh module not loaded, set xmod imag as primary?

    Posted 10-18-2017 17:38
    Hi chahid,

    You could also try to use EXOS 16.2, 21.x, or 22.x.
    It is because that starting in EXOS 16.2, 21.x and 22.x the SSH module is integrated into the standard EXOS image.

    https://gtacknowledge.extremenetworks.com/articles/Q_A/Where-is-the-SSH-module-for-EXOS

    Best regards,


  • 4.  RE: ssh module not loaded, set xmod imag as primary?

    Posted 10-18-2017 23:56
    Chahid,

    As stated by Patrick, boot the switch to the secondary partition and check the status of the SSH access is Enabled in "show management".

    In case, if it isn't Enabled. Execute the command "run update" and then "enable ssh2" and check the SSH access.