ExtremeSwitching (EXOS)

  • 1.  How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 07:47
    If i read the documentation correctly it should be possible to combine standard tagged Vlans and VMAN Selective QinQ CEP on one port? I just can't figure out how to get it working. When i enable CEP the CLI says: Error: 45: Port cannot belong to VLAN and a VMAN at the same time Does anybody have any experience with this configuration?


  • 2.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 08:00
    What commands did you use on what kind of switch and EXOS version ?



  • 3.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 08:04
    Hi Michael.
    I use this config on my network.

    enable jumbo-frame ports all
    configure vman ethertype 0x8100create vman "corp-vman1"
    configure vman corp-vman1 tag 201
    configure vman corp-vman1 add ports 25 tagged
    configure vman corp-vman1 add ports 1-24 cep cvid 1100 - 1500
    configure vman corp-vman1 add ports 1-24 cep cvid 2500 - 3999[/code]


  • 4.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 08:14
    Thanks for the responses. I can creat the CEP setup to do selective QinQ. What i would like to achieve is to have all tagged Vlans pass trough But then also have selective QinQ enabled to put one or two vlan in a VMAN. This is my configuration: create vlan 1 configure vlan 1 tag 1 create vlan 2 configure vlan 2 tag 2 create vlan 3 configure vlan 3 tag 3 configure vlan 1 add ports 44-48 tagged configure vlan 2 add ports 44-48 tagged configure vlan 3 add ports 44-48 tagged enable jumbo-frame ports all configure vman ethertype 0x8100 create vman "vman1" configure vman vman1 tag 605 What i want to do is: configure vman vman1 add ports 45 cep cvid 1001 So then normal vlans pass trough but vlan 1001 is wrapped in a s-tag 605


  • 5.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 08:17
    Does it work if you change the ethertype of the vman to something else than 8100 ?


  • 6.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 09:03
    With another ethertype it shows the same problem. According to xos concepts guide combination of CEP and tagged vlans should be possible


  • 7.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 09:11
    It should be supported yes, what kind of switch you are doing this ?
    Does it work when only 1 vlan is added tagged to the port instead of 3 ?



  • 8.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 09:42
    Hi Oscar, I have the X670 G1 as core switches. I just found the problem. If a port is connected to the default VLAN 1 it does not work. You have to take the port out of Vlan 1 default and then the CEP function works without issue.. Should be noted in the documentation.. 🙂 Thanks for the help!


  • 9.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 09:48
    Hi Michael, you cannot have a vman and a vlan untagged to a port, so this default vlan that is on all ports by default was causing the problem.
    Thanks for the update and finding the cause.


  • 10.  RE: How to combine Selective QinQ CEP with standard tagged vlan on a port?

    Posted 06-03-2015 09:50
    Thank Oscar, You're right. Should have removed the vlan or removed all ports configuring the switch the first time... 😉