ExtremeSwitching (EXOS)

Expand all | Collapse all

Cannot ping in/out of switch but can ping through it

  • 1.  Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 18:30
    I recently setup a new extreme switch that I am having a problem with. The switch itself is not able to ping out and other devices aren't able to ping it. .Though I am able to ping through the switch. For example:

    laptop>problem switch> netgear switch>dhcp server works.

    All configuration settings are factory default except DHCP client has been enable.

    Info:
    [/code]SysName: X440G2-24t-G4
    SysLocation:
    SysContact: support@extremenetworks.com" target="_blank" rel="nofollow noreferrer noopener">support@extremenetworks.com, +1 888 257 3000
    System MAC: 00:04:96:A0:86:10
    System Type: X440G2-24t-G4
    SysHealth check: Enabled (Normal)
    Recovery Mode: All
    System Watchdog: Enabled
    Current Time: Wed Jan 24 19:20:37 2018
    Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
    Boot Time: Wed Jan 24 18:46:59 2018
    Boot Count: 71
    Next Reboot: None scheduled
    System UpTime: 33 minutes 37 seconds[/code]Current State: OPERATIONAL
    Image Selected: secondary
    Image Booted: secondary
    Primary ver: 22.3.1.4
    Secondary ver: 22.4.1.4
    Config Selected: test2.cfg
    Config Booted: test2.cfg
    Config Automatic: NONE (Disabled)

    Untagged ports auto-move: Inform
    -------------------------------------------------------------------------------- ---------------
    Name VID Protocol Addr Flags Proto Po rts Virtual
    Ac tive router
    /T otal
    -------------------------------------------------------------------------------- ---------------
    Default 1 192.168.101.132/24 -f----------T--------------- ANY 2 /28 VR-Default
    Mgmt 4095 ------------------------------------------------ ANY 0 /1 VR-Mgmt
    -------------------------------------------------------------------------------- ---------------
    Ori Destination Gateway Mtr Flags VLAN Duration
    #bo Default Route 192.168.101.2 1 UG-D---um--f- Default 0d:0h:36m:37s
    #d 192.168.101.0/24 192.168.101.132 1 U------um--f- Default 0d:0h:36m:38s

    Does anyone know what could be causing this issue? It persists through power cycling. The workaround is to enable ipforwarding, which is unusual as I haven't had to do that with other switches.


  • 2.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 18:35
    Can you dump a running config here?


  • 3.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 18:58
    Brad,

    are your devices in the same subnet as the switch?

    if not do the devices have a default gateway to reach the switch?

    also, is it possible that you may have a duplicate ip address on the network?


  • 4.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 19:11
    Here is current config:

    # Module vlan configuration.
    #
    configure vlan default delete ports all
    configure vr VR-Default delete ports 1-28
    configure vr VR-Default add ports 1-28
    configure vlan Default add ports 1-28 untagged
    configure Default ipaddress eui64 fe80::/64

    #
    # Module mcmgr configuration.
    #

    #
    # Module fdb configuration.
    #

    #
    # Module rtmgr configuration.
    #

    #
    # Module policy configuration.
    #

    #
    # Module aaa configuration.
    #

    #
    # Module acl configuration.
    #

    #
    # Module bfd configuration.
    #

    #
    # Module cfgmgr configuration.
    #

    #
    # Module dosprotect configuration.
    #

    #
    # Module dot1ag configuration.
    #

    #
    # Module eaps configuration.
    #

    #
    # Module edp configuration.
    #

    #
    # Module elrp configuration.
    #

    #
    # Module ems configuration.
    #

    #
    # Module epm configuration.
    #

    #
    # Module erps configuration.
    #

    #
    # Module esrp configuration.
    #

    #
    # Module ethoam configuration.
    #

    #
    # Module etmon configuration.
    #

    #
    # Module exsshd configuration.
    #

    #
    # Module gptp configuration.
    #

    #
    # Module hal configuration.
    #

    #
    # Module idMgr configuration.
    #

    #
    # Module ipSecurity configuration.
    #

    #
    # Module ipfix configuration.
    #

    #
    # Module lldp configuration.
    #

    #
    # Module mrp configuration.
    #

    #
    # Module msdp configuration.
    #

    #
    # Module netLogin configuration.
    #

    #
    # Module netTools configuration.
    #
    enable dhcp vlan Default

    #
    # Module nodealias configuration.
    #

    #
    # Module ntp configuration.
    #

    #
    # Module rip configuration.
    #

    #
    # Module r.png configuration.
    #

    #
    # Module snmpMaster configuration.
    #

    #
    # Module stp configuration.
    #

    #
    # Module techSupport configuration.
    #
    enable tech-support collector

    #
    # Module telnetd configuration.
    #

    #
    # Module tftpd configuration.
    #

    #
    # Module thttpd configuration.
    #

    #
    # Module twamp configuration.
    #

    #
    # Module vmt configuration.
    #

    #
    # Module vsm configuration.

    Brian all devices are on same subnet and I unplugged the switch with 192.168.101.132 IP address and pinged that IP again and wasn't able to find another device.



  • 5.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 19:18
    Thanks Brad. I think you need to simply add the IP to your default vlan. "config vlan default ipaddress x.x.x.x y.y.y.y"


  • 6.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 19:59
    My IP address is assigned by the DHCP server.
    Error: DHCP/BOOTP is enabled on the VLAN

    Does anyone know why enabling IP forwarding resolves the issue? As well why am I able to ping through the switch, but the switch isn't able to ping other devices and vice versa?


  • 7.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 20:19
    Not 100% sure, but I think that DHCP might be getting assigned to the management VLAN (which is connected to the management virtual router), not the default vlan. Therefore it's not local to the LAN segment and requires that routing be enabled to respond. This is a hunch, as we always statically assign the IP's to the vlan we're managing from (not usually the built-in management vlan). Hopefully someone more knowledgeable on this config will comment.


  • 8.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 20:36
    Okay. Thanks for your help Eric.


  • 9.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-24-2018 21:20
    I forgot to mention one troubleshooting step I took was isolate two extreme switches. Enable a DHCP server on one and DHCP client on the problematic switch. I power cycled the problematic switch 10 times and was able to ping the DHCP server each time.


  • 10.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-26-2018 12:45
    Hi, I also experiencing the same issue. X440 G2. The 2 laptop cannot ping each other in the same vlan. I opened a case and they want to upgrade my version and use a wireshark to see the packet drops. You can open a case for this. Thanks, Newbie


  • 11.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-26-2018 12:45
    what was the solution to this issue as im having a similar issue with a new switch install x440 g2.

    my switch can ping other switches as well as google but the hosts on the same switch and vlan cant ping eachother,

    I can see the mac addresses of the devices


  • 12.  RE: Cannot ping in/out of switch but can ping through it

    Posted 01-26-2018 12:45
    https://community.extremenetworks.com/extreme/topics/ttl-expired-in-transit

    Please see the link I posted recently. Even I configure the IP forwarding my switch does not able to ping other hosts even they are all untag in default vlan