ExtremeSwitching (EXOS)

Expand all | Collapse all

x460-48t experience "Packet transmit error"

  • 1.  x460-48t experience "Packet transmit error"

    Posted 11-12-2018 23:32
    Dealing with this issue past 5 years plus after many calls with TAC, engaged local Extreme SE and still no resolution of the issue.

    We have this X460-24t in our lab networks experience "Packet transmit error" every 60 days or less. The only way to get the network back online is to reboot the switch.

    When the issue occurred, we can still remote access to the switch by telnet or ssh, ICMP (ping) to VLAN interface(s) IP address response okay from other networks.

    Here's the issue,

    After login the switch and ping failed at local VLAN interface IP address; it get an error "Packet transmit error".

    SVPerf-R5-2_SW1.11 # ping 10.52.0.1
    Ping(ICMP) 10.52.0.1: 4 packets, 8 data bytes, interval 1 second(s).
    Packet transmit error
    Packet transmit error
    Packet transmit error
    Packet transmit error

    --- 10.52.0.1 ping statistics ---
    0 packets transmitted, 0 packets received, 0% loss
    round-trip min/avg/max = 0/0/0 ms
    SVPerf-R5-2_SW1.12 # ping 10.52.16.1
    Ping(ICMP) 10.52.16.1: 4 packets, 8 data bytes, interval 1 second(s).
    Packet transmit error
    Packet transmit error
    Packet transmit error
    Packet transmit error

    Has anyone experience this?





  • 2.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 01:07
    Hi Josh,

    Usually when ARP is not resolved for an IP, we see this error. Any number of reasons can cause this - including bugs, network issues, etc. We would need to know the full picture before a cause can be deduced. What is the version of code running on the switch? And is this IP 10.52.16.1 directly connected? Does the same VLAN exist on the switch? Is the ARP resolved correctly during the time of the issue?


  • 3.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 02:08
    Hi Josh,

    It looks like in the last case created for this, the Support Engineer recommended a code upgrade based on xos0066921. Have you been able to update the switches yet?

    Thanks
    Brad


  • 4.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 14:10
    Hello,

    The switch currently running version ExtremeXOS version 16.1.4.2 16.1.4.2-patch1-7.



  • 5.  RE: x460-48t experience "Packet transmit error"

    Posted 11-15-2018 16:30
    Hi Josh,

    It sounds like this issue is different than the one we replicated in the lab. Please open a case with GTAC so we can investigate further.

    Regards,
    Brad


  • 6.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 01:07
    Hi Sushruth,

    It's not a host but it's the VLAN interface IP address failed on ICMP.

    Here's the captured when the issue occurred:
    SVPerf-R5-2_SW1.10 # show vlan
    -----------------------------------------------------------------------------------------------
    Name VID Protocol Addr Flags Proto Ports Virtual
    Active router
    /Total
    -----------------------------------------------------------------------------------------------
    AB13 4094 10.52.96.1 /19 -f--------------------------- ANY 2 /2 VR-Default
    Default 1 --------------------------------T---------------- ANY 5 /17 VR-Default
    Mgmt 4095 ------------------------------------------------- ANY 0 /1 VR-Mgmt
    perflab_16 4093 10.52.16.1 /20 -f--------------------------- ANY 1 /1 VR-Default
    perflab_32 4092 10.52.32.1 /20 -f--------------------------- ANY 3 /3 VR-Default
    perflab_48 8 10.52.48.1 /20 -f--------------------------- IP 3 /3 VR-Default
    perflab_core 4090 10.52.0.1 /20 -f--------------------------- IP 5 /15 VR-Default
    perftransit 4089 10.252.0.10 /24 -f--------------------------- IP 1 /1 VR-Default
    -----------------------------------------------------------------------------------------------
    Flags : (B) BFD Enabled, (c) 802.1ad customer VLAN, (C) EAPS Control VLAN,
    (d) Dynamically created VLAN, (D) VLAN Admin Disabled,
    (e) CES Configured, (E) ESRP Enabled, (f) IP Forwarding Enabled,
    (F) Learning Disabled, (h) TRILL Enabled, (i) ISIS Enabled,
    (I) Inter-Switch Connection VLAN for MLAG, (k) PTP Configured,
    (l) MPLS Enabled, (L) Loopback Enabled, (m) IPmc Forwarding Enabled,
    (M) Translation Member VLAN or Subscriber VLAN, (n) IP Multinetting Enabled,
    (N) Network Login VLAN, (o) OSPF Enabled, (O) Flooding Disabled,
    (p) PIM Enabled, (P) EAPS protected VLAN, (r) RIP Enabled,
    (R) Sub-VLAN IP Range Configured, (s) Sub-VLAN, (S) Super-VLAN,
    (t) Translation VLAN or Network VLAN, (T) Member of STP Domain,
    (v) VRRP Enabled, (V) VPLS Enabled, (W) VPWS Enabled, (Z) OpenFlow Enabled

    Total number of VLAN(s) : 8
    SVPerf-R5-2_SW1.11 # ping 10.52.0.1
    Ping(ICMP) 10.52.0.1: 4 packets, 8 data bytes, interval 1 second(s).
    Packet transmit error
    Packet transmit error
    Packet transmit error
    Packet transmit error

    --- 10.52.0.1 ping statistics ---
    0 packets transmitted, 0 packets received, 0% loss
    round-trip min/avg/max = 0/0/0 ms
    SVPerf-R5-2_SW1.12 # ping 10.52.16.1
    Ping(ICMP) 10.52.16.1: 4 packets, 8 data bytes, interval 1 second(s).
    Packet transmit error
    Packet transmit error
    Packet transmit error
    Packet transmit error

    --- 10.52.16.1 ping statistics ---
    0 packets transmitted, 0 packets received, 0% loss
    round-trip min/avg/max = 0/0/0 ms
    SVPerf-R5-2_SW1.13 # ping 10.52.32.1
    Ping(ICMP) 10.52.32.1: 4 packets, 8 data bytes, interval 1 second(s).
    Packet transmit error
    Packet transmit error
    Packet transmit error
    Packet transmit error



  • 7.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 02:08
    There is a GTAC Knowledge article created for this as well.

    https://extremeportal.force.com/ExtrArticleDetail?n=000013072


  • 8.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 14:10
    Hi Josh,

    It sounds like the switch needs to be updated then. The versions on the switch don't include the fix. The fix is included in the following versions:

    • EXOS 22.3.1
    • EXOS 21.1.3.7 Patch 1-7
    • EXOS 16.2.3
    • EXOS 15.3.5.2 Patch 1-14
    The current recommended version for the X460-48t is EXOS 16.2.5.4-patch1-3.

    Thank you,
    Brad



  • 9.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 14:10
    Hi Josh,

    This looks to be the same issue as described in xos0066921 and the article I linked above. This fix is not included in EXOS 16.1.4.2-patch1-7. Please upgrade to one of the fixed releases as was recommended in the last case you opened for this issue in February.


  • 10.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 14:10
    Sorry.. I provided wrong switch version. Any how, the switch is on the same version you recommended:

    SVPerf-R5-2_SW1.2 # show version
    Switch : 800537-00-04 Rev 4.0 BootROM: 2.0.2.3 IMG: 16.2.4.5
    PSU-1 : EDPS-300AB A-S6 800386-00-06 1135E-41752
    PSU-2 : EDPS-300AB A-S9 800515-00-03 1335E-40902

    Image : ExtremeXOS version 16.2.4.5 16.2.4.5-patch1-8 by release-manager
    on Thu May 3 13:24:01 EDT 2018
    BootROM : 2.0.2.3
    Diagnostics : 6.4
    SVPerf-R5-2_SW1.3 #



  • 11.  RE: x460-48t experience "Packet transmit error"

    Posted 11-13-2018 14:10
    Is there an option within the switch to restart a process or services beside reboot the switch?