ExtremeSwitching (EXOS)

Expand all | Collapse all

Problems with MVR enabled Summit X460 G2

  • 1.  Problems with MVR enabled Summit X460 G2

    Posted 12-03-2018 13:12
    Hi we configured our switch with 2 VLANs.
    The first VLAN called "internal" have some devices communicating.
    On the switch's port 1 there is a computer that sends commands to the devices and take replies back.
    The second VLAN called "external" have some external computers that can communicate with the computer on port 1, so the port 1 is tagged to belong to both VLANs.
    On the internal VLAN we have some streaming devices that send Video in multicast. The video should arrive on the computers on the external VLAN.
    To be able to see the video, we simply enabled MVR for the "Internal" VLAN:
    configure mvr vlan internal
    enable mvr
    We are now able to see the video from external Vlan but we also have some problems in the internal VLAN, some devices doesn't work as expected, and the computer on port 1 read some error responses.

    What could cause the problem?
    If we disable the mvr, the errors are gone but we can't see the video from external Vlan as expected


  • 2.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-03-2018 18:53
    Can you give us a bit more detail on what isn't working when MVR is enabled? Are the issues you are seeing limited to multicast, or is unicast traffic affected too?


  • 3.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-04-2018 07:53
    The issue i see is on a unicast communication between a computer on port 1 and a device(modbus).
    The computer read continously the state of the device. After MVR enabled, the device is replying with an error code. The device is connected to an other small switch, but i'm not aware of the configuration or if this could cause the problem.


    I was thinking about allowing only some multicast addresses of my interest to be forwarded ouside the "Internal" vlan, but i'm not sure how to write the code


  • 4.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-04-2018 11:48
    Hi,

    With all the multicast streams allowed between the vlans, there is a possibility that the port is congested with all the multicast traffic going out of the ports.

    Please check for any congestion on the ports.

    • show port congestion.


  • 5.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-05-2018 10:59
    I tried with the congestion but i didn't see anything. I see instead an unexpected beheaviour.
    I enabled Wireshark on port 6 of the switch, port 6 belongs to the "Internal" VLAN. I have also some streaming devices in the "Internal" VLAN that send video in multicast.

    I don't see any traffic on port 6 and this is right since IGMP snooping is enabled and the port is not interested in the streaming, if i open VLC and open the multicast stream address, i see the multicast packets.
    If i enable MVR, i suddently see all the video streaming on the port even if i'm not registered to any video stream! Why is this happening?


  • 6.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-05-2018 12:54
    Hi Francesco

    thanks for your response.

    While opening the VLC application could you check on the switch side if the port is subscribed to all groups .

    Show igmp snooping vlan

    it is possible that the igmp membership report is sent by the application making the switch port to subscribe to all groups .


  • 7.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-05-2018 14:32
    Hi,

    static MVR does not rely on IGMP joins and bypasses IGMP snooping, see e.g. https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-Static-MVR-regardless-of-IGMP-join/.

    Thanks,
    Erik


  • 8.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-05-2018 14:36
    Hi,

    there may well be another problem: The GTAC Knowledge article https://about:blank describes a bug where multicast traffic is flooded in a VLAN if one router port is added to the VLAN. This issue (xos0064960) is supposed to be fixed in current EXOS version.

    Thanks,
    Erik


  • 9.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-05-2018 14:40
    Hm, the above post did not correctly include the link, and editing did not work for me. :-(

    GTAC Knowledge article name: High Port utilization noticed on MVR receiver port
    URL: https://gtacknowledge.extremenetworks.com/articles/Solution/High-Port-utilization-noticed-on-MVR-receiver-port/
    Link: https://gtacknowledge.extremenetworks.com/articles/Solution/High-Port-utilization-noticed-on-MVR-receiver-port/


  • 10.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-06-2018 09:38
    Thanks Erik for the reply. I have some questions
    1)If i understand MVR enable all the Multicast traffic INSIDE the enabled VLAN to be static so replicated in all the ports right?
    2)The VLANs OUTSIDE don't see the traffic unless a host register to the desired multicast stream right?

    3)What do you mean by "router port"? In my system i added a tagged port to the VLAN. I haven't configured any receiver MVR ports.

    4)I'm interested that multicast stream can be seen OUTSIDE the VLAN, should i configure the MVR as dynamic in order to achieve this and reduce the bandwidth INSIDE the VLAN?

    5)If i specify the MVR to be dynamic (with policy file) but i don't specify the address range, i understand that ALL multicast traffic INSIDE the VLAN will be dynamic right?

    6)Why the default is static? There can be problems with dynamic?


  • 11.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-06-2018 12:48
    Hi Francesco,

    I have not yet used MVR, so I can only try to add some documentation links:
    • https://gtacknowledge.extremenetworks.com/articles/How_To/How-To-Pass-Multicast-Traffic-on-an-Extreme-Switch/
    • https://gtacknowledge.extremenetworks.com/articles/How_To/How-To-Configure-MVR/
    • https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-Static-MVR-regardless-of-IGMP-join/
    Thanks,
    Erik


  • 12.  RE: Problems with MVR enabled Summit X460 G2

    Posted 12-06-2018 13:26
    thanks Erik i will check that
    can you please reply to my questions?