ExtremeSwitching (EXOS)

Expand all | Collapse all

Multicast problem with dynamically created vlans

  • 1.  Multicast problem with dynamically created vlans

    Posted 10-11-2018 09:14
    Hi,
    following scenario:
    - two AccessSwitchstacks X450-G2 (22.4), each connected with an MLAG to a pair of Summit X620 Distributionswitches. (X450 <=> X620 <=> X450)
    - VLAN A is configured in all Switches
    - VLAN B is configured in X620 and dynamically created (via Netlogin) in X450 (f.e. SYS_VLAN_123)

    In VLAN B Multicast-using devices (Bonjour in this case) can not see each other if they are not on the same access switch.

    Using "show mcast cache" I see the Uplink Port towards the distribution switch (port 1:49) is only shown in configured VLANs and not in dynamically created VLANs.
    f.e. configured VLAN A :
    snoop 224.0.0.18 172.16.128.3 43 A
    Vlan Port Vid
    A 1:22 1460
    1:23 1460
    2:34 1460
    2:38 1460
    1:49 1460[/code]dynamically crated VLAN B (1155):
    snoop 224.0.0.1 141.45.139.151 81 SYS_VLAN_1155
    Vlan Port Vid
    SYS_VLAN_1155 1:23 1155
    1:24 1155
    2:3 1155
    2:4 1155[/code]Everything is tagged on Uplink Ports. So I think we have a problem with Multicast packets over Uplinks in dynamically created VLANs. The Switches are running Multicast default configuration. Is there something I have to configure für dynamic VLANs?



  • 2.  RE: Multicast problem with dynamically created vlans



  • 3.  RE: Multicast problem with dynamically created vlans

    Posted 10-11-2018 09:24
    Yes, this is the method we use to add dynamically created VLANs to our Uplink Portsshow config vlan
    ...
    configure vlan dynamic-vlan uplink-ports add ports 1:49[/code]And those VLANs are affected with our multicast problems.