ExtremeSwitching (EXOS)

Expand all | Collapse all

IP CAM performance issue with X450 G2

Ronald Dvorak

Ronald Dvorak04-11-2017 11:38

Erik Auerswald

Erik Auerswald04-12-2017 09:01

Arjumand Qazi

Arjumand Qazi04-12-2017 09:39

Arjumand Qazi

Arjumand Qazi04-13-2017 12:35

  • 1.  IP CAM performance issue with X450 G2

    Posted 04-09-2017 07:34
    Hello, looking for a possible solution, just unboxed X450 G2 and connected IP Cams to it, it should work smoothly. but here video is not stable and lagging.



  • 2.  RE: IP CAM performance issue with X450 G2

    Posted 04-09-2017 17:51
    What is the port speed and duplex? Did auto-negotiation worked correctly?

    Was there something else in the network connected? Any option for some multicast / broadcasts hitting the camera?



  • 3.  RE: IP CAM performance issue with X450 G2

    Posted 04-10-2017 10:35
    Is this connected to another 460? What is the setup?


  • 4.  RE: IP CAM performance issue with X450 G2

    Posted 04-10-2017 13:32
    Is there a possibility for a layer 2 loop in the network?


  • 5.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 11:37
    hello, all he IP cams and the controller are connected to one X450 switch that switch is not connected anywhere else, the issue is our client tested 8 switches of the same type but with all X450 switches same result is coming. the video is too slow. but when connected to any other 3rd party switch the video feed is smooth.


  • 6.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 11:38
    I am sorry gentlemen but is this a normal behavior of sumit switch?


  • 7.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 11:38
    no


  • 8.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 11:51
    I'd check what the guys above mentioned - running the wrong port speed sounds plausible.
    Might be that the port runs at 10/half.


  • 9.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 11:59
    hello, the switch in default configuration will have only auto sensing right ?


  • 10.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 12:04
    yes, could you please post the output/screenshot of the following commands...

    show switch
    show port no-refresh

    And please tell us the ports that have the cams connected.


  • 11.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 12:07
    Additional interesting command output would be from
    show port configuration no-refresh[/code]


  • 12.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 12:11
    have informed our client about the commands, waiting for the output. please bear with me.
    anyway thanks for your support gentlemen.. much appreciated.


  • 13.  RE: IP CAM performance issue with X450 G2

    Posted 04-11-2017 12:29
    I assume it is layer 2 Multicast traffic, can you check if the VLAN in which the controller and IP cams residing has an IP address if not please assign an IP to the VLAN and check if that improves the performance?

    "configure vlan


  • 14.  RE: IP CAM performance issue with X450 G2

    Posted 04-12-2017 08:08
    hello, just went through some datasheets of IP CAMs, the issue is really strange here. the IP CAMs connected to X450 are half duplex and X450 does not support half duplex operation. what can be the possible solution for this scenario ?


  • 15.  RE: IP CAM performance issue with X450 G2

    Posted 04-12-2017 09:01
    The X440-G2 switches half-duplex.


  • 16.  RE: IP CAM performance issue with X450 G2



  • 17.  RE: IP CAM performance issue with X450 G2

    Posted 04-12-2017 09:39
    thanks for the link.


  • 18.  RE: IP CAM performance issue with X450 G2

    Posted 04-12-2017 14:56
    Dumb solution... Buy a 25 dollar cheap unmanaged switch, plug it into the 440, plug your half duplex cameras into the cheap switch... you can get ones with PoE pass-through, or ones that provide some PoE. I have had to do this before...


  • 19.  RE: IP CAM performance issue with X450 G2

    Posted 04-12-2017 14:56
    At the office I used an 800 series 8 port switch lying around to connect an old rack monitoring system that supported only 10Mbps half-duplex Ethernet.


  • 20.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:35




  • 21.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:35
    Please post the output of the following commands from the EXOS switch:
    • show ports configuration no-refresh
    • show ports rxerrors no-refresh
    • show ports txerrors no-refresh
    That should allow us to check port settings like speed, duplex, and flow control, as well as possible errors that might hint at duplex mismatch.

    Another possibility involves IGMP snooping, seeing that the screenshot shows received multicast packets.

    Thanks,
    Erik


  • 22.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:40
    with cisco and extreme same is the out, when we do show ports command. unfortunetely i dont have output for extreme right now.
    the Full-Duplex suggest the end device connected to the switch is using full-duplex operation, can it be possible for the end device to be half duplex and here the port is full-duplex (shown). or there will something like "duplex mismatch" added to this output.

    since there is no configuration on even cisco switch to the default mode here also will be "autonegotiate" if autonegotaite is enabled it doesnt matter if the end device incoming connection is half duplex or full.. the port will always show full-duplex.. please correct if i am wrong here.



  • 23.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:40
    Back in the day, Ethernet supported half-duplex only. Switches allowed full-duplex operation as long as point-to-point links were used. Auto-negotiation is used to determine if half- or full-duplex should be used. If auto-negotiation does not negotiate full-duplex, half-duplex is used.

    Many recent switch ASICs from Broadcom do not support half-duplex operation, thus the problems with really old end systems that do not properly support auto-negotiation and/or full-duplex operation.

    Duplex mismatch cannot be detected reliably using just standard Ethernet, thus some proprietary method to convey that information is used. Cisco Discovery Protocol can include information about the duplex mode used, which is used by (some) Cisco devices to report "duplex mismatch" between e.g. a Cisco router and a Cisco switch. That does not work for other device combinations.


  • 24.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:50
    will try to elaborate further..

    by default for any switch vendor the ports will be in "autonegotiate" mode and the ports will be in full-duplex operation mode. now if we want to connect a half duplex device and "autonegotiate" is enabled, what should the "sh port" command show? half duplex or full duplex?



  • 25.  RE: IP CAM performance issue with X450 G2

    Posted 04-13-2017 12:50
    Duplex is negotiated, thus the show output should display the negotiated mode. If the port does not support half-duplex, you would not expect that to ever show "half-duplex."