ExtremeSwitching (EXOS)

  • 1.  Warning: No IP interface is in routing mode

    Posted 14 days ago
    Edited by Martin Schmidt 14 days ago
    I'm building a new layer 3 switch with some VLANs and OSPF. I've built the VLANs, but when I go to try and enable OSPF I get this:

    I'm building the new user access switch stack. I've created the VLANs, and now I'm trying to enable OSPF...

    * Slot-1 MY-SWITCH.127 # enable ospf
    Warning: No IP interface is in routing mode
    Error: Failed to enable OSPF

    * Slot-1 MY-SWITCH.128 #
    * Slot-1 MY-SWITCH.128 #


    What's it trying to tell me? What am I missing or forgetting?  Yes. I have already enabled IP forwarding.


  • 2.  RE: Warning: No IP interface is in routing mode

    Posted 13 days ago
    Martin,

    Are you using VRs?  It's posable that the Router ID is in the wrong VR?  The "Enable OSPF" command that you showed will enable OSPF for VR-Default.  You might need to "vr <your-VR>" then use enable OSPF. 

    Thanks,

    Stephen



  • 3.  RE: Warning: No IP interface is in routing mode

    Posted 12 days ago
    Thanks Stephen. I'm not sure what I did, but I've fixed it.


  • 4.  RE: Warning: No IP interface is in routing mode

    Posted 12 days ago

    Martin,

    This warning indicates that no VLANs have been enabled for routing.
    Warning: No IP interface is in routing mode

    To correct, you would need to enable ipforwarding (routing) for relevant VLANs:

    enable ipforwarding vlan <VLAN>