ExtremeSwitching (EXOS)

Expand all | Collapse all

stacking switch lose internet

  • 1.  stacking switch lose internet

    Posted 12-29-2017 13:25
    This is probably a super basic question, but I'm at a loss why this is happening.

    I have a pfsense firewall with LAN hooked up to slot 1 on my x440 g2. I want to enable redundancy so I purchased a second x440 g2, but when I plug the switch into slot 49 and 50 (ethernet connected 49-49, 50-50), I suddenly drop internet. I feel like it's trying to grab internet from the new switch rather than my firewall. Both switches are back to factory settings.

    Any help would be greatly appreciated. Thank you.


  • 2.  RE: stacking switch lose internet

    Posted 12-29-2017 14:23
    Joe, be sure to start by upgrading all switches to the same firmware level before connecting. I would also suggest you start with factory defaults on each. Once in this state, connect out of the top switch in to the second. With a console connection to the top unit, type "enable stacking" after they've fully come online.


  • 3.  RE: stacking switch lose internet

    Posted 12-29-2017 14:45
    You are creating a loop. Perhaps you need to configure LACP between 49 and 50 ports on both switches?


  • 4.  RE: stacking switch lose internet

    Posted 12-29-2017 15:27
    Thanks, will take a look at it.


  • 5.  RE: stacking switch lose internet

    Posted 12-29-2017 15:32
    Hi Joe,

    Touching on Nick's point it does sound like you are creating a loop. Eric's point sounds like it's the best way forward. You will need to configure stacking if it hasn't been done already.

    Once stacking is configured, you will need to configure link aggregation on the pfsense side first, by creating and building a "LAGG" with the interfaces you are trying to utilize. Once done create your link sharing LACP ports on the switch, 1:49-50, 2:49-50.



  • 6.  RE: stacking switch lose internet

    Posted 12-30-2017 14:22
    Awesome, thanks fellas.