ExtremeSwitching (EXOS)

ssh key isn't surviving a reboot

  • 1.  ssh key isn't surviving a reboot

    Posted 01-08-2014 00:56
    Create Date: Aug 29 2013 12:19PM

    I have one Summit which refuses to preserve its ssh key after a reboot. This is the case even after upgrading the firmware (including the ssh.xmod) and disabling and reenabling ssh. I've even tried providing a pregenerated key. (and saving before rebooting of course).

    After upgrading several switches, using the same procedure for all of them, one of those switches is now also exhibiting this symptom, while the rest all went fine. The new switch in question was upgraded from 15.3.1.4 to 15.3.2.11p1-2, and ssh was working fine before the upgrade.

    Is the key stored in a particular (apparently hidden) file? Where can I look or what can I do to fix this?

    I just tried:
    dis ssh
    save
    reboot
    en ssh
    yes (10 minute key generation)
    save
    show ssh2 priv (shows that the key is there
    reboot

    But that didn't work either; after the reboot: show ssh2 priv (just a blank line) and attempts to ssh to the switch are rejected.

    sho cpu | include ssh
    exsshd 0.0 0.0 0.0 0.0 4.8 0.8 0.4 99.9 0.10 0.15


    (from xxiii)