ExtremeSwitching (EXOS)

Expand all | Collapse all

Port congestion drops, microbursts or something else

  • 1.  Port congestion drops, microbursts or something else

    Posted 08-07-2017 11:10
    Hi

    BD X8 chassis, BDXA-10G48X module, sw 15.5.2.9

    A port operating as 10G is displaying about 2500-4000 pps constant drop rate with "show port congestion" command.
    At the same time "show port util" is displaying 13% peak TX BW.

    The cause for such a high drop rate with only 13% peak BW is not immediately obvious.
    Do you think microbursts might cause this?

    "conf ports XX shared-packet-buffer 100" did not make any difference.
    As reported by "sh port XX buffer" there is either 8MB or 2MB max shared buffer (depending on configuration).

    If this is a microburst issue the solution would be a 2x10GE LAG.
    But if this a SW bug the LAG is useless.

    The traffic loading this link is (mostly) multicast.

    Thanks



  • 2.  RE: Port congestion drops, microbursts or something else

    Posted 08-08-2017 22:23
    Hi Mick,
    Did you try to replace the cable,fiber or SFP to ger rid of the physical issue? And you could identify the microburst congestion with Wireshark by youself from below link.


  • 3.  RE: Port congestion drops, microbursts or something else



  • 4.  RE: Port congestion drops, microbursts or something else

    Posted 03-06-2018 03:58
    Hi,

    Kindly add "Port congestion" on hub for your reference
    https://community.extremenetworks.com/extreme/topics/port-congestion

    Best regards,
    Bin


  • 5.  RE: Port congestion drops, microbursts or something else

    Posted 04-22-2019 19:31
    Could micro bursts also affect just the CPU?

    I was investigating a very random video issue and the only thing I have found so far is congestion on the CPU.

    Slot-1 WWPS-X670-Core.1 # debug hal show congestion
    Congestion information for slot 1 type X670G2-48x-4q since last query
    CPU congestion present: 399432073

    Congestion information for slot 2 type X670G2-48x-4q since last query
    CPU congestion present: 719827618

    Slot-1 WWPS-X670-Core.2 # debug hal show congestion
    Congestion information for slot 1 type X670G2-48x-4q since last query
    No switch fabric or CPU congestion present

    Congestion information for slot 2 type X670G2-48x-4q since last query
    No switch fabric or CPU congestion present

    TOP looks good and there are no issues other than this very random video issue.

    Thanks,