ExtremeSwitching (EXOS)

Expand all | Collapse all

sFlow not sampling on x670-48x

  • 1.  sFlow not sampling on x670-48x

    Posted 06-23-2015 15:47
    Any way to show the sflow config without showing all config?
    Not getting samples. What am I missing here?

    X670-48x
    Image : ExtremeXOS version 15.6.1.4 v1561b4 by release-manager on Tue Sep 30 14:06:19 EDT 2014
    BootROM : 2.0.1.7
    Diagnostics : 6.3
    ....
    configure sflow poll-interval 30
    configure sflow collector 10.90.2.19 port 6343 vr "VR-Default"
    configure sflow agent ipaddress 10.25.1.5
    enable sflow
    ....

    SFLOW Statistics

    Received frames : 10341258740
    Sampled Frames : 0
    Transmitted Frames : 110895
    Broadcast Frames : 33825358
    Multicast Frames : 27781614
    Packet Drops : 0
    ....

    # sh sflow config
    SFLOW Global Configuration
    Global Status: enabled
    Polling interval: 30
    Sampling rate: 8192
    Maximum cpu sample limit: 2000
    SFLOW Configured Agent IP: 10.25.1.5 Operational Agent IP: 10.25.1.5
    Collectors
    Collector IP 10.90.2.19, Port 6343, VR "VR-Default"

    SFLOW Port Configuration
    Port Status Sample-rate Subsampling Sflow-type
    Config / Actual factor Ingress / Egress
    1 enabled 8192 / 8192 1
    2 enabled 8192 / 8192 1
    3 enabled 8192 / 8192 1
    4 enabled 8192 / 8192 1
    5 enabled 8192 / 8192 1
    6 enabled 8192 / 8192 1
    7 etc... all 48 ports

    From GTAC KB, but did not change anything...

    Resolution
    Unconfigure sflow collector by typing the command:
    • unconfigure sflow collector [i]
    Configure sflow collector by typing the command:
    • configure sflow collector [i] port [u] vr


  • 2.  RE: sFlow not sampling on x670-48x

    Posted 06-23-2015 15:59
    Randy,

    The "show configuration etmon" command can be used to view the sflow configuration. Can the sflow collector (10.90.2.19) ping the switch at 10.25.1.5?

    -Andrew



  • 3.  RE: sFlow not sampling on x670-48x

    Posted 06-23-2015 17:08
    Thank you. Yes, it can ping.

    Collector to switch and switch to collector, zero loss.


  • 4.  RE: sFlow not sampling on x670-48x

    Posted 06-23-2015 17:35
    Randy,

    Was sflow previously working or is this a new setup? Please post the output of "show configuration etmon."

    -Andrew


  • 5.  RE: sFlow not sampling on x670-48x

    Posted 06-23-2015 17:47
    It was working. Had not checked in awhile. In fact, I haven't opened FlowTraq for a few weeks due to other matters and just hadn't had the time / need. So, not sure how long it has been down.

    BTW, that's definately part of the problem. And not sure why that dropped, but thank you, I did miss that.

    Still not showing up in the collector, but now it is sampling, so there may be an issue with ProQueSys and this should solve the Extreme side.

    SFLOW Statistics
    Received frames : 10422586690
    Sampled Frames : 653
    Transmitted Frames : 112099
    Broadcast Frames : 34308845
    Multicast Frames : 28282301
    Packet Drops : 0

    # sh conf etmon#
    # Module etmon configuration.
    #
    configure sflow poll-interval 30
    enable sflow
    configure sflow collector 10.90.2.19 port 6343 vr "VR-Default"
    configure sflow agent ipaddress 10.25.1.5
    enable sflow ports 1 ingress
    enable sflow ports 2 ingress
    enable sflow ports 3 ingress
    enable sflow ports 4 ingress
    ....
    enable sflow ports 47 ingress
    enable sflow ports 48 ingress

    # sh sflow conf
    SFLOW Global Configuration
    Global Status: enabled
    Polling interval: 30
    Sampling rate: 8192
    Maximum cpu sample limit: 2000
    SFLOW Configured Agent IP: 10.25.1.5 Operational Agent IP: 10.25.1.5
    Collectors
    Collector IP 10.90.2.19, Port 6343, VR "VR-Default"

    SFLOW Port ConfigurationPort Status Sample-rate Subsampling Sflow-type
    Config / Actual factor Ingress / Egress
    1 enabled 8192 / 8192 1 enabled / disabled
    2 enabled 8192 / 8192 1 enabled / disabled
    3



  • 6.  RE: sFlow not sampling on x670-48x

    Posted 06-23-2015 17:59
    Randy,

    One thing that can be done to isolate the issue a bit further would be to run a packet capture using Wireshark on the sflow collector. Doing so can confirm whether or not the sampled traffic is making it to the collector.

    -Andrew


  • 7.  RE: sFlow not sampling on x670-48x

    Posted 06-24-2015 10:03
    Wireshark shows flows making it to server (not sure how to put a screenshot here).
    Pretty sure you solved my Extreme issue and now this is a FlowTraq issue.
    Thank you!!!


  • 8.  RE: sFlow not sampling on x670-48x

    Posted 08-13-2019 10:44
    In my case with x440 unconfigure sflow collector then configure sflow collector didn't resolve the issue.
    My resolution:
    code:
    disable sflow ports all
    enable sflow ports all

    Now sFlow sampling works fine!