ExtremeSwitching (EXOS)

Expand all | Collapse all

Summit X-Series, Problem with curent time

Ronald Dvorak

Ronald Dvorak01-10-2018 12:40

  • 1.  Summit X-Series, Problem with curent time

    Posted 01-10-2018 06:49
    Hi, at all!

    We have a problem with some switches x450 with the firmware 22.2.1.5 and higher. We configure the timezone with this syntax:

    "configure timezone name MEZ 60 autodst name MESZ 60 begins every last sunday march ends every last sunday october"

    But when I show the current time with "show switch", there is a difference about 20 or 30 minutes.

    What's the problem and how can I solve it?

    Thanks for all answers!



  • 2.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 06:57
    Hi Carsten.

    this is only the timezone and summertime configuration. To set the current day and time, you need a ntp or manual time config as well.

    X460G2-24p-10G4.1 # configure time 01 10 2018 08 55 30

    hth

    Alexander



  • 3.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 08:20
    Hi, Alexander!

    Thanks for your post.

    We have an NTP Server. I have forgotten to mention ist. The syntax is:

    Enable ntp vlan [name]

    Configure ntp server add [Server IP] burst

    Any another idea?

    Carsten





  • 4.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 08:30
    could you post a screenshot of "show ntp", "show ntp ass" and "show ntp sys"


  • 5.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 10:09
    Show ntp:

    NTP : Enabled
    Authentication : Disabled
    Broadcast-Client : Disabled
    VR : VR-Default

    Show ntp association:

    VR Name:VR-Default Remote:[Server IP] Reference ID:INIT St:16 Poll:1024 Reach:0 Delay: 0.00000 Offset: +0.00000 Disp: 3.99217

    Show NTP sys-info:

    System Peer : 0.0.0.0
    System Peer Mode : Unspec
    Leap Indicator : 11
    Stratum : 16
    Precision : -15
    Root Distance : 0.00000 second
    Root Dipersion : 333.958 second
    Reference ID : [init]
    Referene Time : 00000000.00000000 Thu, Feb 7 2036 7:28:16.000
    System Flags : Monitor, NTP, Kernel, Stats
    Jitter : 0.000000 second
    Stability : 0.000 ppm
    Broadcast Delay : 0.007996 second
    Auth Delay : 0.000000 second



  • 6.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 10:26
    Stratum 16 (=local clock) shows that the switch isn't synced to the NTP.

    Do a "show vlan" - what VR is the switch IP using ? Is it VR-default or VR-mgmt ?
    You'd try disable/enable NTP, are you able to ping the NTP from the switch ?

    You'd also try another NTP to test, I use 83.218.160.135 for example on my lab switch.


  • 7.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 11:18
    The Switch IP is using vr vr-default and i can ping the Server who offers the NTP. I've disabled and enabled the NTP. But the shown time is still about 15 minutes to far.

    The other NTP IP is blocked by the firewall.

    Any other ideas?



  • 8.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 12:40
    Could you try a reboot ?


  • 9.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 14:25
    Hi, Ronald!

    The switches are rebootet already. Without any success.



  • 10.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 21:46
    Hi Carsten,

    Can you give us the output of 'show config ntp'? Feel free to remove any IP addresses if you don't want to post them publicly.


  • 11.  RE: Summit X-Series, Problem with curent time

    Posted 01-11-2018 06:29
    Hi, Brandon!

    # Module ntp configuration.
    #
    enable ntp vr VR-Default
    enable ntp vlan [VLAN ID]
    configure ntp server add [Server IP] burst vr VR-Default



  • 12.  RE: Summit X-Series, Problem with curent time

    Posted 01-11-2018 11:43
    SOLUTION!!!

    We found a solution for that problem. We had to add the transfernet with the syntax

    enable NTP vlan [Transfernet]

    and then the sending IP was added as the local interface.

    Thanks for everyone, who sehnd an answer!



  • 13.  RE: Summit X-Series, Problem with curent time

    Posted 01-11-2018 11:58
    Hi Carsten.

    Thanks for providing the solution. That´s very good to know!

    regards
    Alexander


  • 14.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 11:18
    Hi.

    please double check if your server is ntp or maybe sntp.

    Here is my example ntp config which works fine:

    4 EXOS Device als NTP-Client

    -Demo.1 # enable ntp vr VR-Default

    -Demo.1 # enable ntp vlan Default

    -Demo.1 # configure ntp server add 10.0.184.254 vr VR-Default




    4 Review der Synchronization

    -Demo.1 # show ntp association 10.0.184.254 statistics

    -Demo.1 # show ntp sys-info

    -Demo.1 # show ntp association


    hth
    Alex


  • 15.  RE: Summit X-Series, Problem with curent time

    Posted 01-10-2018 11:18
    Hi, Alex!

    I just have put the syntax on one switch again. Here ist the result:

    Slot-1 [name].11 # show ntp association [Server IP] statistics
    VR Name : VR-Default
    Remote Host : [Server IP]
    Local Interface : 0.0.0.0
    Time Last Received : 112 seconds
    Time Until Next Send: 22 seconds
    Reachability Change : 112 seconds
    Packets Sent : 0
    Packets Received : 0
    Bad Authentication : 0
    Bogus Origin : 0
    Duplicate : 0
    Bad Dispersion : 0
    Bad Reference Time : 0
    Candidate Order : 0

    I can ping the server from the switch.



  • 16.  RE: Summit X-Series, Problem with curent time

    Posted 01-11-2018 06:29
    Another Information:

    We have Summits which are simply L2-switches. There NTP is OK. I can see the MGMT-IP as the local interface. The Switches who are L3 - Switches, theres is no NTP Funktion. There is not the MGMT-IP the local IP. You can see ist above. There is no local interface. The NTP Server IP is reachable on every Switch.