ExtremeSwitching (VSP)

 View Only
  • 1.  Preferred Upgrades for 5520

    Posted 01-07-2022 12:29
    We're a new customer to the Extreme equipment with some 5520's and was wondering how often we should be updating the VOSS software or if there was a document that had a preferred version to run?  I understand that everyone's environment is different with different features enabled but how close does everyone stay to the latest release?  We're currently running 8.4.1.0 but see we are about 4 releases behind latest (8.4.3.0).


  • 2.  RE: Preferred Upgrades for 5520

    Posted 01-08-2022 09:35
    Hello,

    When you have a stable network running for a longer time then there is no real reason to upgrade.

    Having said that, there are several reasons to upgrade and to not upgrade.
    • There is a maintenance contract, then you must run a supported version (usually only the latest main releases are supported).
    • Running a main release (e.g. 7.5.x, 8.2.x or 8.4.x) then check the later release notes in that version for important solved issues, in your case the release notes for 8.4.2.0 and 5.4.3.0.
    • There is a new feature introduced that is interesting for you.
    • You have a strategy to always run the latest version, in that case it is smart to wait for some time before upgrading to it.
    • You have a strategy to always run the oldest contractual supported version.
    • Did I forgot some? ....

    regards
    WillyHe


  • 3.  RE: Preferred Upgrades for 5520

    Posted 01-08-2022 09:53
    Kyle,

    You should upgrade from 8.4.1 to at least 8.4.2 due to a bug in the 8.4.1 causing an unexpected reboot when executing the command "show fulltech".
    For the normal upgrade process, on top of the comment WillyHe, you should also keep an eye on the end of sw support time line.

    So you should upgrade only if you have a good reason for that.
    A good reason being a bug to solve, a new feature needed, a SW becoming out of support.

    Regards

    Mig



  • 4.  RE: Preferred Upgrades for 5520
    Best Answer

    Posted 01-10-2022 09:56
    As always, read the release notes for any upgrade you are considering as there may be an unresolved issue that could cause a problem in your environment. That said, I try to follow the recommended releases from Extreme whenever possible.

    Software Release Recommendations for VOSS/VSP 8600 - Extreme Networks

    You can subscribe for updates to that page.


  • 5.  RE: Preferred Upgrades for 5520

    Posted 01-10-2022 11:07
    Thank you all for the comments and recommendations.