ExtremeSwitching (EOS)

Expand all | Collapse all

LAG X690 between SFP and UTP

  • 1.  LAG X690 between SFP and UTP

    Posted 03-05-2018 20:40
    Hello i have a Stack between two switch model X690 one of then 10G fiber an other of copper switch. But when i make a lag show the following error. It is possible to make a lag between 10G copper +10 G fibber?

    =========================

    XXXXXXXXX # show ports 1:48,3:48 configuration no-refresh
    Port Configuration
    Port Virtual Port Link Auto Speed Duplex Flow Load Media
    router State State Neg Cfg Actual Cfg Actual Cntrl Master Pri Red
    ================================================================================
    1:48 VR-Default E R OFF 10000 FULL NONE
    3:48 VR-Default E A ON 10000 10000 FULL FULL SYM 3:48 UTP
    ================================================================================
    XXXXXXXX# configure sharing 3:48 add ports 1:48

    Error: Member Port 1:48 has Auto Negotiation Off while Master Port has Auto Negotiation On

    Configuration failed on backup Node, command execution aborted!

    ===================================================





  • 2.  RE: LAG X690 between SFP and UTP

    Posted 03-05-2018 20:43
    try to enable autonegotiation on 1:48



  • 3.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 13:18
    No ten gig, 40 gig, or 100 gig interface should have auto negotiation on... Standard is off You should set them both to off not on .. this will allow your lag to complete.


  • 4.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 05:55
    The error indicates that one link has auto negotiation on, the other off. Tun on auto negotiation on on both 10Gbit links.


  • 5.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 09:10
    Hello i cant change the auto neg in 1:48, Is the first that i have tried ...
    ======================
    ********** # configure ports 1:48 auto on speed 10000 duplex full
    Error: Auto negotiation is not supported on port 1:48 at 10G speed

    Configuration failed on backup Node, command execution aborted!
    *********
    Also i have a LAG between to 10G UTP ports and works perfect, only fails when i add to the sharing group the 10G fiber port.


  • 6.  RE: LAG X690 between SFP and UTP

    Posted 03-07-2018 09:06
    Anybody know if its possible to make a LAG betweem 10g fiber and 10g copper? or could be a bug.?


  • 7.  RE: LAG X690 between SFP and UTP

    Posted 03-05-2018 23:57
    Sorry for provide inaccurate answer, I will try to update below article.
    https://gtacknowledge.extremenetworks.com/articles/Q_A/Is-it-possible-to-create-a-LAG-with-a-combina...


  • 8.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 09:10
    Is there any 1G SFP had been installed on the switch?


  • 9.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 09:10
    No steven All sfp are 10Gb . Why ?

    Port Configuration
    Port Virtual Port Link Auto Speed Duplex Flow Load Media
    router State State Neg Cfg Actual Cfg Actual Cntrl Master Pri Red
    ================================================================================
    1:1 VR-Default E R OFF 10000 FULL SF+_SR
    1:2 VR-Default E R OFF 10000 FULL SF+_SR
    1:3 VR-Default E R OFF 10000 FULL SF+_SR
    1:4 VR-Default E R OFF 10000 FULL SF+_SR
    1:5 VR-Default E R OFF 10000 FULL SF+_SR
    1:6 VR-Default E R OFF 10000 FULL SF+_SR
    1:7 VR-Default E R OFF 10000 FULL NONE
    1:8 VR-Default E R OFF 10000 FULL SF+_SR



  • 10.  RE: LAG X690 between SFP and UTP

    Posted 03-06-2018 13:18
    Hello i also tried to setup 3:48 to auto OFF but it not supported the following error says:
    ==============
    XXXXXXX # configure ports 3:48 auto off speed 10000 duplex full
    Error: Auto negotiation off is not supported on port 3:48 at 10 Gbps speed.
    Configuration failed on backup Node, command execution aborted!
    * XXXXXX #



  • 11.  RE: LAG X690 between SFP and UTP

    Posted 03-07-2018 09:06
    GTAC solution
    After looking into this i have found that it is not possible to create a lag with mixed UTP and fiber ports.

    Auto-negotiation is mandatory for 10GbBase-T according to the 802.3 standard, while it’s not possible on fiber due to the possible different wavelengths of light and different signal timing in the various types of transceivers.

    Unfortunately there is no way around this.
    ===================================

    It not possible by the moment


  • 12.  RE: LAG X690 between SFP and UTP

    Posted 01-10-2020 06:08

    You can try bypass this. If you put base-t tranciever into SFP+ slot then x690 will change autonegotiation to ON and spped to 1000. Then you can try to add port to sharing.

    I did something similar yesterday. Before inserting tranciever:

    2:46     VR-Default E       R   OFF 10000       FULL                    NONE

    after inserting:

    2:46     VR-Default E       R    ON  1000       AUTO              1:47  1000T

     

    regards,

    Tomek
     



  • 13.  RE: LAG X690 between SFP and UTP

    Posted 03-05-2018 23:57
    EXOS support mix fiber and UTP port in the same sharing group when the port speed and duplex same.