Data Center (SLX)

Expand all | Collapse all

slx 9140 trunk configuration

  • 1.  slx 9140 trunk configuration

    Posted 02-26-2018 09:12
    When I try to configure a trunk port on the slx 9140 I get following error

    Testsystem02(config)# interface Ethernet 0/1

    Testsystem02(conf-if-eth-0/1)# Switchport mode trunk

    %%Error: Interface not bound to bridge

    Testsystem02(conf-if-eth-0/1)#

    Do you have any hints?



  • 2.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 09:35
    Hi I am not familiar with this specific error, but to configure a switchport to trunk mode, first you need to enable switching on the interface.
    interface Ethernet 0/1
    switchport
    switchport mode trunk[/code]Regards
    Mick


  • 3.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 09:45
    Unfortunately no. It doesn't work.



  • 4.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 09:51
    Could you please include the rest of your configuration, so that the error can be put into context


  • 5.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 09:56
    Testsystem02# sh run
    clock timezone Etc/GMT
    hardware
    profile tcam default
    profile route-table default maximum_paths 8
    system-mode default
    !
    http server use-vrf default-vrf
    http server use-vrf mgmt-vrf
    logging raslog console INFO
    logging auditlog class SECURITY
    logging auditlog class CONFIGURATION
    logging auditlog class FIRMWARE
    logging syslog-facility local LOG_LOCAL7
    logging syslog-client localip CHASSIS_IP
    switch-attributes chassis-name SLX9140
    switch-attributes host-name Testsystem02
    no support autoupload enable
    support ffdc
    resource-monitor cpu enable threshold 90 action raslog
    resource-monitor memory enable threshold 100 action raslog
    resource-monitor process memory enable alarm 1000 critical 1200
    snmp-server contact "Field Support."
    snmp-server location "End User Premise."
    snmp-server sys-descr "Brocade BR-SLX9140 Router"
    snmp-server enable trap
    system-monitor fan threshold marginal-threshold 1 down-threshold 2
    system-monitor fan alert state removed action raslog
    system-monitor power threshold marginal-threshold 1 down-threshold 2
    system-monitor power alert state removed action raslog
    system-monitor temp threshold marginal-threshold 1 down-threshold 2
    system-monitor cid-card threshold marginal-threshold 1 down-threshold 2
    system-monitor cid-card alert state none action none
    system-monitor compact-flash threshold marginal-threshold 1 down-threshold 0
    system-monitor MM threshold marginal-threshold 1 down-threshold 0
    system-monitor LineCard threshold marginal-threshold 1 down-threshold 2
    system-monitor LineCard alert state none action none
    system-monitor SFM threshold marginal-threshold 1 down-threshold 2
    telemetry profile system-utilization default_system_utilization_statistics
    ..truncated
    !
    telemetry profile interface default_interface_statistics
    ..truncated
    !
    line vty
    exec-timeout 10
    !
    threshold-monitor Buffer limit 70
    vrf mgmt-vrf
    address-family ipv4 unicast
    ip route 0.0.0.0/0 172.17.0.1
    !
    address-family ipv6 unicast
    !
    !
    ssh server key rsa 2048
    ssh server key ecdsa 256
    ssh server key dsa
    ssh server use-vrf default-vrf
    ssh server use-vrf mgmt-vrf
    telnet server use-vrf default-vrf
    telnet server use-vrf mgmt-vrf
    role name admin desc Administrator
    role name user desc User
    aaa authentication login local
    aaa accounting exec default start-stop none
    aaa accounting commands default start-stop none
    service password-encryption
    username admin password "BwrsDbB+tABWGWpINOVKoQ==\n" encryption-level 7 role admin desc Administrator
    username user password "BwrsDbB+tABWGWpINOVKoQ==\n" encryption-level 7 role user desc User
    cee-map default
    precedence 1
    priority-group-table 1 weight 40 pfc on
    priority-group-table 15.0 pfc off
    priority-group-table 15.1 pfc off
    priority-group-table 15.2 pfc off
    priority-group-table 15.3 pfc off
    priority-group-table 15.4 pfc off
    priority-group-table 15.5 pfc off
    priority-group-table 15.6 pfc off
    priority-group-table 15.7 pfc off
    priority-group-table 2 weight 60 pfc off
    priority-table 2 2 2 1 2 2 2 15.0
    remap lossless-priority priority 0
    !
    vlan 1
    !
    vlan 5
    name test
    !
    vlan 3820
    router-interface Ve 3820
    name LAN-Switch
    !
    qos map cos-mutation all-zero-map
    ...truncated
    !
    protocol lldp
    system-description Brocade BR-SLX9140 Router
    !
    vlan dot1q tag native
    police-remark-profile default
    !
    class-map cee
    !
    class-map default
    !
    no protocol vrrp
    no protocol vrrp-extended
    interface Ve 3820
    ip proxy-arp
    ip address 172.17.0.8/21
    shutdown
    !
    interface Management 0
    no tcp burstrate
    no shutdown
    vrf forwarding mgmt-vrf
    no ip address dhcp
    ip address 172.17.0.7/21
    !
    interface Ethernet 0/1
    switchport
    switchport mode access
    switchport access vlan 1
    no shutdown
    !
    interface Ethernet 0/2
    switchport
    switchport mode access
    switchport access vlan 1
    shutdown
    !
    ..truncated


  • 6.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 10:24
    hi Giuseppe ,
    what version you are running ??



  • 7.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 11:06
    17s.1.00


  • 8.  RE: slx 9140 trunk configuration

    Posted 02-26-2018 11:58
    tried on my device here and it woked . (9240) downgraded to your version
    so you can try on the port a "no switchport" --> "switchport " ---> " switchport trunk"
    if you still see the same error message i suggest to open a case with GTAC