ExtremeWireless (WiNG)

Expand all | Collapse all

Cant upgrade attached AP7522 firmware

Carlos Assunção

Carlos Assunção05-08-2018 08:13

  • 1.  Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 07:30

    Hello,

    I woud like to update/upgrade our Wing AP7522 APs from 5.8.6.9 to 5.9.1.1.

    I using the express UI.

    When I update the virtual controller, only this one will be upgraded after the progress. The other three will not.

    I have tried several options:

    1. I tried upgrade the VC (this should be the standard way, right?)
    2. I tried to downgrade to 5.8.6.0. first. I thought it might still be the same bug. please refer: https://extremeportal.force.com/ExtrArticleDetail?an=000081096
    3. I tried upgrade the attached APs over its own Webinterface. When I do this, the AP will startup with the new Firmware then goes down by itself and startup next with the old firmware.

    What am I doing wrong? Thank you for your help in advance



  • 2.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 07:36
    Hi,
    Make sure that you are forcing the correct boot system.

    Thru Console cable what are you seeing?

    Thanks


  • 3.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 07:37
    One more question, Are your AP WiNG Express or WinG native?


  • 4.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 07:53
    Hi,

    I don't use the Console.

    The APs are AP7522 not AP7522E. But the UI and System in Use is WiNG Express (I think).

    Excuse my poor English




  • 5.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:13
    Did you try to update the AP individualy?



  • 6.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:17
    Hi Matz,

    The interface is referred to as Swift - but shouldn't be a an issue for you (it's nice and user-friendly!)

    In the screen where you sent the screenshot - underneath the text "Managed Access Points' There is a drop-down 'Tools' menu. Is there a firmware upgrade option in that menu?You will need to check the boxes on the left hand side to select which APs to upgrade.

    Many thanks,
    Darrel.


  • 7.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:30
    I have a ssh connection now. The AP 192.168.0.232 (NOT THE VC) has the firmware 5.8.6.0 as Secondary Image (witch I tried to load (see Point 2 in my Post ). How can I load the Secondary Image for the next boot? "boot system secondary" doesn't work. It shows "% Invalid input detected at '^' marker." So "boot" is not available.



    Many Thanks


  • 8.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:43
    You have to perform the upgrade of VC (express) a second time, this will load the device image to the VC that it will use to upgrade the adoptees.


  • 9.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Hallo Matze, ich denke du sprichst deutsch, oder?
    Steht das Image 5.9.1.4 auf dem VC für die adopted AP's zum download bereit?
    Check das mal über die Console auf dem VC mit dem Befehl:
    show device-upgrade versions
    Sollte so aussehen:
    CONTROLLER DEVICE-TYPE VERSION
    --------------------------------------------------------------------------------
    AP7522_VC ap7522 5.9.1.4-003R

    Wenn nicht musst du das Image noch auf den Controller laden. Ich mache das immer mit tftp32 von meinem PC aus. Das geht aber auch über das GUI glaub ich.
    In der CLI wäre der Befehl folgender:
    AP7522_VC#device-upgrade load-image ap7522 tftp://xxx.xxx.xxx.xxx/AP7522-5.9.1.4-004R.img
    -> Bereitstellen der Firmware für AutoUpgrade der Antennen.

    Danach updaten sich die AP's kpl. selbstständig. Wichtig ist das du immer das Vollimage benutzt und nicht das LEAN-Image. Das hat nämlich keine GUI.
    Wo sitzt du in D?

    Gruß

    Sebastian



  • 10.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:13
    yes

    "3. I tried upgrade the attached APs over its own Webinterface. When I do this, the AP will startup with the new Firmware then goes down by itself and startup next with the old firmware."


  • 11.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:17
    Yes. That's what I tried. However, only the VC is upgraded after the progress.



  • 12.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:17
    The interface is referred to as Swift
    btw - I think Swift is a old Name. Its called WiNG Express now?!

    https://documentation.extremenetworks.com/WiNG/5.9.0/9035125_WiNG_Express_5_9_UG.pdf

    Very confusing the whole interfaces, systems, companies (Motorola, Zebra, EN) etc.


  • 13.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 08:17
    WING Express is on APs that have E on the end of the part number, example AP7522E vs non-express AP7522.


  • 14.  RE: Cant upgrade attached AP7522 firmware



  • 15.  RE: Cant upgrade attached AP7522 firmware



  • 16.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Hallo Sebastian,

    vielen Dank für deine Hilfe! Leider funktioniert das so noch nicht.

    als Ausgabe von "show device-upgrade versions"
    erhalte ich:

    --------------------------------------------------------------------------------
    CONTROLLER DEVICE-TYPE VERSION
    --------------------------------------------------------------------------------
    1OG-links ap7522 none
    1OG-links ap7532 none
    1OG-links ap7562 none
    --------------------------------------------------------------------------------[/code]
    Abgesehen davon dass anscheint keine Version verfügbar ist, steht dort als Device-Type ap 7532. Ich bin mir aber sicher bspw. nie ein fremdes Image auf die APs geladen zu haben. Und die APs sind alles 7522 (ohne E).

    Anschließend habe ich
    1OG-links>enable[/code]und
    1OG-links#device-upgrade load-image ap7522 ftp://systemftp:#####@192.168.0.221/admin/AP7522-5.9.1.4-004R.img[/code]ausgeführt an der Ausgabe von "show device-upgrade versions" ändert sich dadurch nichts.

    Noch eine Idee? Wir sitzen in der Nähe von Köln (Bergisches Land).

    VG

    Matthias


  • 17.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Ok,

    nochmal ausgeführt, jetzt erhalte ich:

    -------------------------------------------------------------------------------- CONTROLLER DEVICE-TYPE VERSION

    --------------------------------------------------------------------------------

    1OG-links ap7522 5.9.1.4-004R

    1OG-links ap7532 5.9.1.4-004R

    1OG-links ap7562 5.9.1.4-004R

    --------------------------------------------------------------------------------

    Also zwar eine Version aber falsche Device-Types.



  • 18.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Ok, ich hab was an der Optik xD

    Ich dachte die drei Zeilen wären die drei anderen APs dabei sind es die Versionen die bereit stehen und in der oberen Zeile steht ja ap7522.

    Nach einem Neustart der APs hat es jetzt auch geklappt.

    Dann werde ich mal noch versuchen auf 5.9.1.5 zu gehen ohne SSH. Sollte ja eigentlich auch über die Weboberfläche gehen.

    Vielen Vielen Dank dir!!

    LG
    Matthias


  • 19.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Servus Matthias,

    gerne, kein Problem!
    Wenn der 1OG-links dein VC ist hast du alles richtig gemacht.
    Mit "#show adoption status" siehst du deine AP's und ob sie die richtige WiNG Version gezogen haben.
    In der GUI auf dem VC siehst du das natürlich auch unter "Access Points"
    Mit WiNG Express hab ich keine Erfahrung aber du musst selbstverständlich die Firmware für die E-Modelle benutzen. In der CLI wird er das E nicht anzeigen, denke ich.
    Die Express Schiene wird von Extreme auch nicht mehr weitergeführt werden.
    Poste doch mal eine Ansicht von "Access Point" deines VC.

    BG

    Sebastian


  • 20.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Hast du überhaupt die Express Variante? Ich glaube fast nicht. Die GUI sieht nämlich gleich aus und heißt oder hieß Swift.
    Was steht den auf dem Karton bei PART NUMBER:
    AP7522E-.... oder ohne E?


  • 21.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Nein nein, sind alles ohne E (das war mir auch klar s. o.) Finde das mit den Namen Express und Swift sehr verwirrend. Ich hatte zuletzt gedacht dass die Oberfläche seit einiger Zeit Express heißt, denn über Swift findet man bei EN so gut wie nichts, auch z. B. keine Dokumentation. Kann es sein, dass Swift ein alter Name von Zebra ist? Das es zudem noch das E Modell gibt, war mir klar. Zu dem Problem: Es hat sich eigentlich nun gezeigt, dass ich alles richtig gemacht hatte. Irgendwas hing da. Nachdem es jetzt dank deiner Hilfe über ssh geklappt hatte konnte ich ein weiteres Upgrade wieder ganz normal über die UI einspielen. Alle anderen APs ziehen es sich automatisch. Danke!


  • 22.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Servus Matze,

    dieses GUI hieß seit seiner Entstehung "SWIFT UI". Ich habe es bei der 5.7.x auf dem AP7522 zum ersten mal gesehen. Damals war das so buggy das ich mir angwöhnt habe die Upgrade-Geschichten über die CLI zu machen. Deshalb habe ich noch nie ein Upgrade über die GUI gemacht.
    Daher jetzt die Frage an dich:
    Wenn man das Upgrade über die GUI macht, steht dann das Image automatisch für die Client-AP's bereit?

    Gruß

    Basti



  • 23.  RE: Cant upgrade attached AP7522 firmware

    Posted 05-08-2018 09:55
    Hey Basti,

    ist ja auch nirgendwo beschrieben wie es durchgeführt wird. Die Radiobutton sind auf jeden Fall mal total unnötig, da halt eh nur der VC (anscheint) ausgewählt werden und diesem ein Upgrade eingespielt werden muss. Dann standen bei mir die Upgrades auch für die attached APs bereit. Da die UI allerdings recht wenig status infos zurück gibt, werde ich wohl in Zukunft auch lieber den CLI weg geht. Schade eigentlich, da beschleicht einen das Gefühl, dass diese Geräte mit Absicht schwer zu warten sind, damit man jedes mal einen Servicetechniker braucht.