ExtremeWireless (WiNG)

Expand all | Collapse all

Configuring different VLANs for Access Points and WLANs

  • 1.  Configuring different VLANs for Access Points and WLANs

    Posted 03-11-2018 21:53
    Hi All,

    I'm new to Extreme wireless.
    Could someone please assist how can we configure the following:

    1. APs get the IP Address from Management Subnet.
    2. WLANs users get the IP Address from different subnet than the APs.

    Thanks.


  • 2.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 00:18
    Hey Moin,
    1. By default, WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1
    2. For WLAN user to get Ip address from a different subnet, multiple ways can be done:
    Hope this helps~!


  • 3.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 00:26
    Hi Madeline,

    Thanks for your reply.
    When you say WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1.
    It is the case when the switchport has no config on it? Correct me if I'm wrong?

    If we want APs to get IP address from a different VLAN, say VLAN10 and WLAN users on VLAN20. Do we need to configure the switchport as a trunk port with native VLAN as VLAN10?


  • 4.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 00:50
    1. When you say WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1.
    It is the case when the switchport has no config on it? Correct me if I'm wrong?
    >> I'll assume that you are referring to AP int ge configuration, and the default behaviour is as below:
    interface ge1
    switchport mode access
    switchport access vlan 1
    interface vlan1
    ip address dhcp
    ip address zeroconf secondary
    ip dhcp client request options all

    2.If we want APs to get IP address from a different VLAN, say VLAN10 and WLAN users on VLAN20. Do we need to configure the switchport as a trunk port with native VLAN as VLAN10?
    >> Yes, on top of that you will need to configured AP interface ge1 to allow VLAN 10 and VLAN 20
    For example:
    interface ge1
    switchport mode trunk
    switchport trunk native vlan 10
    no switchport trunk native tagged
    switchport trunk allowed vlan 10,20



  • 5.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 03:27
    Hi Madeline,

    Thanks for the detailed response. I didn't know if we could configure the AP int Ge interface with switchport commands.

    In my case I'd have to configure the following:

    AP Ge Interface:
    switchport mode trunk
    switchport trunk native vlan 10
    no switchport trunk native tagged
    switchport trunk allowed vlan 10,20

    interface vlan 10
    ip address dhcp
    ip address zeroconf secondary
    ip dhcp client request options all

    Switchport Config (Where AP is connected)

    interface gi1/0/1
    switchport mode trunk
    switchport trunk native vlan 10
    switchport trunk allowed vlan 10,20

    The Switch Config:

    interface vlan 10
    ip address 192.168.10.1 255.255.255.0
    ip helper-address [i]

    interface vlan 20
    ip address 192.168.20.1 255.255.255.0
    ip helper-address [i]

    Does it make any sense?


  • 6.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 04:12
    Dear Moin,

    I am not sure about the switch that you are using, but from the WiNG AP side, the configuration looks correct
    You can do a show IP interface brief on the AP to check the IP address that it is taking

    Hope this helps


  • 7.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 04:56
    Assuming we have Cisco Switches.
    Does the config look good?

    Thanks.


  • 8.  RE: Configuring different VLANs for Access Points and WLANs

    Posted 03-12-2018 04:56
    We are sorry to hear that :-)

    It looks OK
    just as a reminder.... you'd need a "no shut" on the VLAN interfaces