ExtremeWireless (WiNG)

Expand all | Collapse all

AP7522 POE issue

Michael Wright

Michael Wright06-10-2017 19:01

Michael Wright

Michael Wright06-12-2017 14:26

  • 1.  AP7522 POE issue

    Posted 06-10-2017 15:47
    Please help, today i have being setting up and configuring 10 AP7522s i have got 7 all working correctly but for some reason 3 have POE issues they are constantly rebooting and do not say up. I have changed the cable, directly connected the AP tried different POE config on the switchports but nothing.

    The switch is providing POE so all i get is the below:

    *Oct 16 10:56:16.747: %ILPOWER-7-DETECT: Interface Fa2/0/23: Power Device detected: IEEE PD
    *Oct 16 10:56:17.787: %ILPOWER-5-POWER_GRANTED: Interface Fa2/0/23: Power granted
    *Oct 16 10:56:22.435: %LINK-3-UPDOWN: Interface FastEthernet2/0/23, changed state to up
    *Oct 16 10:56:24.463: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to up
    *Oct 16 10:56:40.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to down
    *Oct 16 10:56:45.744: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to up
    *Oct 16 10:57:01.191: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to down
    *Oct 16 10:57:05.926: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to up
    *Oct 16 10:58:03.314: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/23, changed state to down
    *Oct 16 10:58:04.328: %LINK-3-UPDOWN: Interface FastEthernet2/0/23, changed state to down
    *Oct 16 10:58:03.390: %ILPOWER-7-DETECT: Interface Fa2/0/23: Power Device detected: IEEE PD
    *Oct 16 10:58:04.396: %ILPOWER-5-POWER_GRANTED: Interface Fa2/0/23: Power granted
    *Oct 16 10:58:09.030: %LINK-3-UPDOWN: Interface FastEthernet2/0/23, changed state to up

    it just repeats over and over

    Please help thanks



  • 2.  RE: AP7522 POE issue

    Posted 06-10-2017 18:56
    Hi Michael

    Do you use any NX platform to manage 7522 APs?
    The PoE you're testing with is 802.3 af?


  • 3.  RE: AP7522 POE issue

    Posted 06-10-2017 19:01
    Yes it's an nx platform and yes it's 802.3af


  • 4.  RE: AP7522 POE issue

    Posted 06-10-2017 19:22
    You can validate that the 3 APs that are restarted, finished updating the Firmware

    You can see it using
    ! ### show adoption status

    !### show adoption history


  • 5.  RE: AP7522 POE issue

    Posted 06-10-2017 19:46
    Tried both commands but I cannot connect to the aps to see their status as they don't power up long enough before they reboot for example

    Show adoption history on xxxxxx
    Error: querying device

    If I just try show adoption status or adoption history I see aps listed but they show adopted unadopted one after the other.

    Any other suggestions?

    Thank you for the help so far!


  • 6.  RE: AP7522 POE issue

    Posted 06-10-2017 19:48
    Tried both commands but I cannot connect to either device to see status they power up long enough before they reboot for example Show adoption history on xxxxxx Error: querying device If I just try show adoption status or adoption history I see aps listed but they show adopted unadopted one after the other. Any other suggestions? Thank you for the help so far!


  • 7.  RE: AP7522 POE issue

    Posted 06-10-2017 22:03
    You can try to connect through the console port to the
    Ap7522 and press the Enter key before loading the system to discard that it is Firmware problem and try to start with the second partition.

    If in this mode the AP restarts I would tell you that it is HW problem and I would request an RMA



  • 8.  RE: AP7522 POE issue

    Posted 06-12-2017 04:11
    Hi,

    do you check the power budget?

    show power inline

    Is it a Cisco or HP switch? Sometimes the negotiation between AP and Switch failed. In this case the AP get full power.


  • 9.  RE: AP7522 POE issue

    Posted 06-12-2017 05:58
    I tried what you suggested Edmundo but it seems its just reloads again. it's a Cisco switch and there is plently of power available to power the APs, This is happening on two different switch located on the network


  • 10.  RE: AP7522 POE issue

    Posted 06-12-2017 06:20
    Hi Michael,

    could you also test only those three affected APs all alone?
    Not necessarily this is a PoE issue. Might be DoA AP...

    Any chance to get console connection for affected APs?
    See description in article here

    Regards,
    Ondrej


  • 11.  RE: AP7522 POE issue

    Posted 06-12-2017 06:27
    Please see attached a video of the console boot you can play this back on tera term, let me know your thoughts

    https://www.dropbox.com/s/mlwbmzhtat6xghg/AP02.tty?dl=0



  • 12.  RE: AP7522 POE issue

    Posted 06-12-2017 07:47
    Can you check, how many watt the APs use and what class the APs report?


  • 13.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    Please see POE output below:

    Interface Admin Oper Power Device Class Max
    (Watts)
    --------- ------ ---------- ------- ------------------- ----- ----
    Fa2/0/23 auto on 15.4 Ieee PD 4 15.4

    Interface AdminPowerMax AdminConsumption
    (Watts) (Watts)
    ---------- --------------- --------------------

    Fa2/0/23 15.4 15.4



  • 14.  RE: AP7522 POE issue

    Posted 06-13-2017 12:52
    One last thing that I'd try, assuming there are other APs at that site that are functioning.:

    1. connecting to a working remote AP at the site via ssh/telnet.
    2. use the command "show mint neighbors" - You will see all APs on the same Layer2 and maybe some Layer 3 neighbors depending on how your config is setup. The Mint-ID which is XX.XX.XX.XX contains part of the MAC address of the AP (the last 3 digits); eg MAC address 5C-0E-8B-11-22-33 will show up as Mint ID: 0B.11.22.33. If it doesn't show up, then the AP is probably hosed.
    3. Try pinging the mint address using the command: "mint ping XX.XX.XX.XX" if you get a response continue to next step.
    4. Now the cool part: use the command: "connect mint-id XX.XX.XX.XX" - This will open a Layer 2 CLI session with the target AP. This is especially useful to get into an AP that doesn't get an IP address for some reason.
    5. You can now troubleshoot / factory default the problem AP.



  • 15.  RE: AP7522 POE issue

    Posted 06-13-2017 13:11
    Thanks, I already checked this and I couldn't see anything I have double checked again still nothing I tried to ping the MINT ID but still no response.

    I will proceed with getting the AP replaced.

    Thank you for all your help!


  • 16.  RE: AP7522 POE issue

    Posted 06-12-2017 11:20
    Can you connect through the console to the APs?

    With this we could confirm if it is HW problem



  • 17.  RE: AP7522 POE issue

    Posted 06-12-2017 11:30
    It doesn't reach the controller, i'm afraid the AP is about 6 hours drive away now so i'm unable to console on to the AP any other suggestions?


  • 18.  RE: AP7522 POE issue

    Posted 06-12-2017 12:37
    Does the AP get a IP address and can you connect? Check for information via LLDP or CDP.

    Do you check the adoption history? Any connection from this AP?


  • 19.  RE: AP7522 POE issue

    Posted 06-12-2017 12:47
    using LLDP I can see a Chassis ID which show an IP address locally obtained by DHCP I can ping the address but i cannot access via SSH.

    I have checked adoption history and I cannot see any info for this AP.


  • 20.  RE: AP7522 POE issue

    Posted 06-12-2017 12:50
    Strange, try do disable and enable PoE to reboot the AP. If this don't work, no idea. Maybe you can try to SSH from the Cisco switch direct, if it's firewall or routing problem.


  • 21.  RE: AP7522 POE issue

    Posted 06-12-2017 13:03
    I've just checked, i misread the LLDP the AP it isn't getting an IP address. tried a reboot several time but nothing.


  • 22.  RE: AP7522 POE issue

    Posted 06-12-2017 13:55
    How is the AP discovering the controller? DHCP options, or something else?


  • 23.  RE: AP7522 POE issue

    Posted 06-12-2017 14:26
    APs are discovered by DHCP options


  • 24.  RE: AP7522 POE issue

    Posted 06-12-2017 14:29
    If the AP is not getting an IP address, this indicates a Layer 2 issue between the DHCP server and the AP.

    This is typically cased by a VLAN mismatch.



  • 25.  RE: AP7522 POE issue

    Posted 06-12-2017 14:39
    I have 10 of these access points 3 on one vlan and 7 on another all of this aps are configured the same and 9 of the 10 have been adopted and are functioning correctly​ The switchport config is Switchport mode trunk Switchport trunk native vlan 4 This access point isn't getting a lease from DHCP no matter which vlan I put it in. Thanks


  • 26.  RE: AP7522 POE issue

    Posted 06-13-2017 04:28
    Native vlan is 4 and DHCP is vlan 1? The AP need a untag VLAN to get a IP address, if it's a clean AP. Do you have free DHCP IPs?

    Check for the right VLAN as untag and available DHCP address. If this are booth right, the AP is damage.


  • 27.  RE: AP7522 POE issue

    Posted 06-13-2017 05:47
    DHCP is Vlan 4 and switchport is trunking Vlan 4, plenty of DHCP leases available within the scope, do we agree this AP is faulty?

    Thanks for everyone's help so far, it's been really helpful!


  • 28.  RE: AP7522 POE issue

    Posted 06-13-2017 11:33
    The fact that you are seeing LLDP info on the switch port indicates that a) the AP booted up OK; b) there is nothing physically wrong with the interface. Both of these facts point to a configuration mismatch of some sort.

    I've seen many instances where the AP has been configured incorrectly either by accident (typos) or due to unintentional behavior caused by profile overrides. The AP's configuration ends up such that the network interface does not match the switch port setting.

    Please post the output of the AP's exected interface config. You can do this from the controller CLI with "show run device device_mac_address" and include all the lines for "interface ge1, interface vlan, etc".

    Also include the switch's interface config for that interface.



  • 29.  RE: AP7522 POE issue

    Posted 06-13-2017 12:01
    AP interface config:

    interface ge1
    switchport mode trunk
    switchport trunk native vlan 4
    no switchport trunk native tagged
    switchport trunk allowed vlan 1-4094
    interface vlan4
    description
    ip address XX.XXX.XX.XX/XX
    ip dhcp client request options all
    ip helper-address XX.XXX.XX.XX

    Switchport config:

    interface FastEthernet2/0/23
    description Link to APXX
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 4
    switchport mode trunk
    no lldp med-tlv-select power-management
    end

    Thanks


  • 30.  RE: AP7522 POE issue

    Posted 06-13-2017 12:25
    A couple comments on the config:

    • It appears that the switch port vlan 4 config is consistent, the problem lies elsewhere.
    • Why is there an IP address listed in interface vlan 4? If you are using dhcp, it should read "ip address dhcp"
    • The DHCP helper is usually configured on the switch, not on the AP. Only the switch has the switch virtual interface (SVI) for vlan 4 should have this configured.
    • "allowing" all VLANs into the AP can cause issues if there are APs on the other VLANs that could be visible over layer 2.



  • 31.  RE: AP7522 POE issue

    Posted 06-12-2017 06:27
    Michael,

    I do see important event "NSM-4-IFDOWN" which basically means that port is shutdown and that is why AP goes into reboot.



    There is good minute and half gap between first and second PD signature in above log, which means AP boots and operates for certain amount of time.

    I do wonder if there is any configuration present on affected APs.
    Are those getting adopted when booting or are those standalone?
    Also, are every time same APs showing the problem? Different ports on switch?

    I do smell hardware issue here...

    Regards,
    Ondrej



  • 32.  RE: AP7522 POE issue

    Posted 06-12-2017 06:27
    I believe the first time they booted they spoke spoke to the NX6500 as its reports the switchports they are connected too, but they seem to no longer do that.

    I have tried different switch ports/switches and still getting the same problem.

    I believe it could be hardware as well, but i just thought it seems to much of a coincidence that three all have the same issue.


  • 33.  RE: AP7522 POE issue

    Posted 06-12-2017 06:27
    Michael,

    if these APs are not stable enough to check configuration there is no way to try i.e. factory reset.

    I'd personally recommend to RMA those affected.

    Regards,
    Ondrej


  • 34.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    3af is more than enough to keep these APs alive.
    My AP7522 lives well, serving MCX, with as high as 7.8mW



    Regards,
    Ondrej



  • 35.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    Looks like a power handling problem? I think it was LLDP-MED that negotiate the power levels between switch and ap. Try to check this settings and disable it.

    Is it possible that the power budget is to low, if the APs get 15.4 Watt?


  • 36.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    Timo,

    Time-Lenght-Value (TLV) extension carries Power via Media-Dependent-Interface (MDI). See snapshot from my lab



    If the power budged is too low AP should not boot correctly as PSE allocated value won't fit classification signature at AP side.

    Disabling the LLDP on each side will bring no negotiation, hence full AF power.
    Which seems to be provided anyway.

    Michale could capture LLDP on switch side to see what is AP asking for, but I am afraid it won't bring much more light. If other switches / ports and cables were tested the fault seems to be at AP side.

    Regards,
    Ondrej


  • 37.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    Timo your advice fixed the problem!! (no lldp tlv-select power-management command fixed it ) out of the three APs I have all but one working, so now my issue is the last AP powers up and stays up but it doesn't get adopted i cannot see it getting a DHCP address.

    Any advice?


  • 38.  RE: AP7522 POE issue

    Posted 06-12-2017 08:03
    show adoption history

    With this command you can see why it's not adopted (if it can reach the controller).


  • 39.  RE: AP7522 POE issue

    Posted 06-13-2017 12:25
    • The APs IP addresses are Static they will be assigned the IP listed under that VLAN
    • DHCP helper address is configured on the SVI of the switch as well as in the profile just for peace of mind at the moment.
    I believe the AP is faulty I have a total of 200 APs on multiple sites all with similar if not the same configuration, they all function correctly. The 10 on this site are all up and functioning correctly with the same configuration listed above, but this one just doesn't obtain an IP address ever.