Network Architecture & Design

Expand all | Collapse all

Loop prevention on LAN

  • 1.  Loop prevention on LAN

    Posted 03-02-2016 00:48
    Our current network configuration, is only running ESRP (active/pasive) no stp or mstp, I'll like to implement some loop prevention configuration. Just today I had an issue in one switch that loose the uplink to the Primary Core, this turn into a failover to the secondary core, and it appear the issue was some kind of loop in a communication closet (I unplugged communication link in the whole closet). What do you suggest, do you think ELRP might help me? Thanks


  • 2.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:55
    Karina,

    Yes, we could configure ELRP to detect the loop. I have included an KB Article for your reference below:-

    https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-ELRP-to-disable-ports



  • 3.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    Yes, ELRP will provide the L2 edge loop protection that you are looking for. It works fantastic and is easy to configure. You need to configure it per port in each vlan and can use options to log, log-and-trap and disable port for a duration or permanently so you can intervene. Check out the options here in the documentation:

    http://documentation.extremenetworks.com/exos/EXOS_All/Troubleshooting/t_configure-standalone-elrp.s...


  • 4.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    I use the vlan default for it.I configure all ports in vlan default tagged, except the uplinks.

    Reason: If someone connects a cable in to ports that belongs to different vlan's it will be also noticed.



  • 5.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    But only for the ELRP or all your port are in vlan default?


  • 6.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    Yes, only for ELRP


  • 7.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    So you enable the ELRP on the Default and tag the ports you want to monitor for LOOPS excluded the uplinks, correct?


  • 8.  RE: Loop prevention on LAN

    Posted 03-02-2016 00:57
    Johan, I'm testing the configuration using the default vlan on stack, It works great, just testing the log part, now, I'm checking the documentation to know if it is possible to block the port and how to do it.


  • 9.  RE: Loop prevention on LAN

    Posted 03-02-2016 01:03
    Thanks, Our Cores are XOS, but I still have some Extremeware Edge switches, the ELRP is configure in each Edge switch, correct?


  • 10.  RE: Loop prevention on LAN

    Posted 03-02-2016 01:07
    ELRP is on Extremeware too, the link to the documentation is here under the archives:

    http://www.extremenetworks.com/support/documentation-archives

    The configuration is very similar.



  • 11.  RE: Loop prevention on LAN

    Posted 03-02-2016 19:07
    Also, when this happen on the server level one of the servers that is running SQL it show this error "Cluster IP address resource 'SQL IP Address (SMTMSSQL) cannot be brought online because a duplicate IP address 'ipofheserver' was detected on the network. Please ensure ll IP addresses are unique.

    On the Cores, there was no ESRP aware flush warning message, only the link down, but on the switch with the issue it did show the esrp warning, I'm not sure if it was so fast that's why... but you know if we need to do some special configuration for servers?

    All of my VLAN's are in one failover domain, will it help if share info from my core configuration?


  • 12.  RE: Loop prevention on LAN

    Posted 03-02-2016 19:07
    <content-quote data-username="Karina Del Moral">Also, when this happen on the server level one of the servers that is running SQL it show this error "Cluster IP address resource 'SQL IP Address (SMTMSSQL) cannot be brought online because a duplicate IP address 'ipofheserver' was detected on the network. Please ensure ll IP addresses are unique.

    On the Cores, there was no ESRP aware flush warning message, only the link down, but on the switch with the issue it did show the esrp warning, I'm not sure if it was so fast that's why... but you know if we need to do some special configuration for servers?

    All of my VLAN's are in one failover domain, will it help if share info from my core configuration?</content-quote>This is a different issue than loop prevention mechanisms. Moving this to a new thread will help get better attention. Please reference the new conversation here: ESRP and failover scenarios