FAQs

G/C/B-Series with "bcm_port_update failed: Operation failed" Error Messages

  • 1.  G/C/B-Series with "bcm_port_update failed: Operation failed" Error Messages

    Posted 12-31-2013 17:11
    Article ID: 13902

    Products
    G-Series, firmware 6.42.01.0046 through 6.42.13.0002
    C5-Series, firmware 6.42.01.0046 through 6.51.02.0018
    C3-Series, firmware 6.42.01.0046 through 6.42.13.0002
    C2-Series, firmware 5.02.01.0006 through 5.02.15.0002
    B5-Series, firmware 6.42.01.0046 through 6.51.02.0018
    B3-Series, firmware 6.42.01.0046 through 6.42.13.0002
    B2-Series , firmware 4.02.01.0006 through 4.02.15.0002

    Symptoms
    One or more "
    code:
    bcm_port_update
    " or "
    code:
    bcm_port_info_get
    " failure errors seen in the current.log (5487).

    For example:

    <
    code:
    160
    >
    code:
    Feb 11 07:20:11 10.5.1.8-1 SIM[89389240]: broad_hpc_drv.c(2689) 102 %% Port ge10: bcm_port_update failed: Operation failed

    <
    code:
    160
    >
    code:
    Feb 25 06:57:53 10.5.1.8-1 SIM[89410464]: broad_hpc_drv.c(2689) 111 %% Port ge14: bcm_port_info_get failed: Operation failed

    <
    code:
    160
    >
    code:
    Apr 21 09:09:19 10.5.1.8-1 SIM[89409648]: broad_hpc_drv.c(2689) 143 %% Port ge10: bcm_port_update failed: Operation failed


    Cause
    Such messages indicate that an internal ethernet port status query or update operation initially failed, then was retried. Ultimately, the necessary operation is performed.

    This symptom is only worthy of pursuit if the messages are logged in quantity, and/or appear in conjunction with an operational symptom such as erratic or reduced port performance.

    Solution
    For the G/C5/C3/B5/B3-Series, upgrade to firmware 6.61.02.0007 or higher (14480).
    For the C2, upgrade to firmware 5.02.16.0008 or higher.
    For the B2, upgrade to firmware 4.02.16.0008 or higher.