FAQs

 View Only

DFE's SNMP MIB Walk Runs Slow when encountering TimeFiltered OIDs

  • 1.  DFE's SNMP MIB Walk Runs Slow when encountering TimeFiltered OIDs

    Posted 12-03-2013 16:03
    Article ID: 10162

    Products
    Matrix N-Series

    Changes
    Performing an SNMP MIB walk.

    Symptoms
    High CPU utilization.

    Some OIDs such as... lldpRemEntry=1.0.8802.1.1.2.1.4.1.1 (ieee/lldp-mib)
    dot1qVlanCurrentEntry=1.3.6.1.2.1.17.7.1.4.2.1 (ietf/Q-BRIDGE-MIB)
    ptopoConnEntry=1.3.6.1.2.1.79.1.1.1.1 (ietf/PTOPO-MIB)
    ctDot1qVlanForbidEgressPorts=1.3.6.1.4.1.52.4.1.2.16.7.1.3.1.1 (ctron-q-bridge-mib-ext)
    ctCDPNeighborEntry=1.3.6.1.4.1.52.4.1.2.19.1.3.1 (ctron-cdp-mib)
    ctAliasEntry=1.3.6.1.4.1.52.4.1.3.7.1.1.1.1 (ctron-alias-mib)[/code] ...take a long time to parse.

    Cause
    These OIDs are time-filtered, so per the RFCs (e.g. RFC3512, RFC4502) must return entries for all valid timeMarks.

    The SNMP browser should understand the behavior of a timeFiltered MIB and move on after seeing the timeFilter index increment. However, not all browsers behave in this manner.

    Solution/Workaround
    Ensure you are using an appropriate SNMP tool - such as NetSight MIB tools - that behaves correctly.

    Workaround:
    DFE firmware 6.01.01.0020 introduced a new command which can accommodate SNMP browsers that are not timeFilter-aware.

    Release notes state, in the "Software Changes and Enhancements" section:A new SNMP control, "set snmp timefilter break", allows users to configure the
    GET-NEXT behavior of MIBs indexed with timeMark. When this is set to 'enabled',
    SNMP will not return incrementing index values. Many SNMP tools do not properly
    support timefiltered MIBs and will benefit from this new setting. When disabled,
    SNMP returns RFC conformant indexing.[/code]
    Here is the command syntax, as seen in a sample cli session: NSeries(rw)->set snmp timefilter

    Command: set snmp Create SNMP agent entries

    Object: timefilter SNMP timefilter configuration
    Usage: set snmp timefilter break {disable | enable}

    break Set SNMP timefilter break (default: disabled)
    disable Disable timefilter break
    enable Enable timefilter break
    NSeries(rw)->[/code]
    Pre-upgrade workaround:
    In the SNMP configuration, exclude (5610) the lldpRemEntry, dot1qVlanCurrentEntry,ptopoConnEntry, ctDot1qVlanForbidEgressPorts, ctCDPNeighborEntry, and ctAliasEntrybranches from the visible MIB Tree: set snmp view viewname All subtree 1
    set snmp view viewname All subtree 0.0
    set snmp view viewname All subtree 1.0.8802.1.1.2.1.4.1.1 excluded
    set snmp view viewname All subtree 1.3.6.1.2.1.17.7.1.4.2.1 excluded
    set snmp view viewname All subtree 1.3.6.1.2.1.79.1.1.1.1 excluded
    set snmp view viewname All subtree 1.3.6.1.4.1.52.4.1.2.16.7.1.3.1.1 excluded
    set snmp view viewname All subtree 1.3.6.1.4.1.52.4.1.2.19.1.3.1 excluded
    set snmp view viewname All subtree 1.3.6.1.4.1.52.4.1.3.7.1.1.1.1 excluded[/code]