End of Service Products

 View Only
  • 1.  GVRP registration problem

    Posted 09-10-2016 17:24
    Hello, I am trying setup GVRP on my older C3G124-24 switches. I have two one in stacked formation. Enabled 24 lacp groups and formed few lags.

    I try to use GVRP on two nodes with latest updated CentOS 7.2.

    Node4 formed lag.0.4 from ports ge.1.4 and ge.2.4
    Node8 formed lag.0.8 from ports ge.1.8 and ge.2.8

    I enable GVRP on that lags using command

    set gvrp enable lag.0.4
    set gvrp enable lag.0.8[/code]On nodes I run this commands

    ip link add link team0 name team0.200 1500 type vlan id 200 gvrp on
    ip link set team0.200 up
    ip addr add 192.168.200.(4|8) dev team0.200
    ip route add dev team0.200[/code]

    When I check status on stack with command

    show vlan
    [/code]I see that vlan 200 is formed with egress ports lag.0.4 and lag.0.8

    Problem is that lag.0.4 after while dissapear from egress ports :(
    I try to delete interface and form it again, but without success.
    I also try to adjust garp timers on port lag.0.4 to 100 300 3000, but result is that port disapears after longer while.
    Same result was with options reorder_hdr off and loose_binding on

    lag.0.8 works without problems. Both nodes have same teamd config, only different are network adapters.

    On node4 are two Intel 82575EB with igb driver
    On node8 are two Broadcom BCM5715 with tg3 driver

    How can I debug whats going on node4? I try to enable local logging with severity 8, but nothing about gvrp is in buffer.

    Thank you.



    team0 interface was assigned to br0 bridge. So I remove it from bridge and instead I assign tagged team0.1 to that bridge br0, so team0 is without bridge and GVRP works fine.

  • 2.  RE: GVRP registration problem

    Posted 09-12-2016 11:59
    Glad you sorted it out Feldsam. Thanks for letting the Hub Community know where you stand.