ExtremeCloud IQ- Site Engine & Extreme Management Center

Expand all | Collapse all

Unable to use https link in Captive Portal page

  • 1.  Unable to use https link in Captive Portal page

    Posted 06-05-2018 14:39
    Hi

    Have a link to a privacy policy URL to an external website in the captive portal page, which I've added to the allowed URL list as such:

    URL

    https://www.website.co.uk/privacy-policy

    Domain

    website.co.uk

    The link is to a https page, and whenever I click on it I get the following error:


    If I click 'Go on to the webpage' it will just redirect me back to the splash page.

    When I look at the certificate its not the one produced by the URL if you go direct, which works fine:



    My assumption is that its jumping from the none http captive portal page to the https page that is issue, but I'm not sure how to correct it.

    Many thanks in advance


  • 2.  RE: Unable to use https link in Captive Portal page

    Posted 06-05-2018 14:49
    Hi Martin,

    You provided a link on the NAC web page yes, but it sounds like its getting redirected to NAC, and hence the error. Do you have a policy on your switch/wireless controller that allows direct connection to this URL? *Note that you cant redirect / proxy HTTPS "through" the NAC appliance. Allowed Domains and URLs that proxy through need to be HTTP. You can handle this with policy on the switch or wireless controller.

    Regards,

    Scott Keene
    NMS/NAC Support



  • 3.  RE: Unable to use https link in Captive Portal page

    Posted 06-05-2018 14:49
    Thanks Scott, you were spot on... that did the trick!

    Much appreciated.


  • 4.  RE: Unable to use https link in Captive Portal page

    Posted 06-05-2018 14:49
    Very good Martin! You're welcome, Im gad that its working now.

    -Scott