ExtremeCloud IQ- Site Engine & Extreme Management Center

  • 1.  Netsight 6.1 Archive Issue

    Posted 07-30-2014 10:55
    I'm having an issue using the archive wizard in Netsight 6.1.

    The archive itself works however the .cfg file is just full of gobbledegook.

    We requested version 6 as version 5 couldn't understand Extreme devices.

    Any takers?


  • 2.  RE: Netsight 6.1 Archive Issue

    Posted 07-30-2014 11:10
    Hi Ian,

    What type of device are you trying to archive? Also what exact version of 6.1 are you using?

    Thanks,

    -Tyler


  • 3.  RE: Netsight 6.1 Archive Issue

    Posted 07-30-2014 13:43
    Hi,

    Well all of our estates but to be more specific, x250s, x450s, x440s, BD10Ks, BD8810s, x670s.

    Running 6.1.0.127


  • 4.  RE: Netsight 6.1 Archive Issue

    Posted 07-30-2014 16:24
    Hi Ian,

    So I just tried it out myself. The file that is pulled off is actually a zipped up directory, even though the filename ends with .cfg. If you're looking to take the config off of the NetSight server, you can download the file and rename it to .zip and then unzip it with your favorite utility. Within there, the xml configuration file as well as a couple other files will be available. If you choose to look at the file from NetSight, either through Inventory Manager or comparing backups via OneView, the server will show you the correct config information.

    I'll follow up with development on this, as the .cfg extension is a bit deceiving.

    Let me know if that solves your problem. I verified this on NetSight version 6.1.0.124 with a Summit X460-24p running 15.4.2.8.

    Thanks,

    -Tyler


  • 5.  RE: Netsight 6.1 Archive Issue

    Posted 07-31-2014 06:41
    Hi Tyler,

    That's great, just what I wanted to hear.

    While we have been able to view the archive through netsight (from your insight) it would be nice to simply take the .cfg and use it as needed.

    We wouldn't use netsight to restore a config to a switch considering we don't attach new blanket switches to the network to replace faulty ones and then upload saved configs.

    Normally we would take the .cfg file and upload locally from a laptop via TFTP and test before installing in live.

    I have tried to rename the .cfg to .zip and while it worked the zip does not display any files when extracting.

    Hope my explanation makes sense.
    Thanks
    Ian


  • 6.  RE: Netsight 6.1 Archive Issue

    Posted 07-31-2014 13:22
    Hi Ian,

    So it looks like the built-in windows zip utility won't unzip it correctly. I tried on my Mac and it worked fine. I just downloaded 7-zip and tried to look at it that way and it unzipped correctly with that utility as well. Try that out and see if it does the trick.

    As for making the .cfg more readable, I would recommend opening up a case with GTAC for that so that it can be turned into a feature request / bug fix (not sure what they would classify it as).

    Thanks,

    -Tyler


  • 7.  RE: Netsight 6.1 Archive Issue

    Posted 08-01-2014 06:03
    Hi Tyler,

    Yep that's perfect. I think we can manage that way to be honest.

    Thanks for your help
    Ian


  • 8.  RE: Netsight 6.1 Archive Issue

    Posted 10-31-2014 14:32
    Hi,

    Wanted to follow this up as I'm having the same issue again that I had prior to this.

    All the switches now fail to archive, the error in Netsight is "config file is empty"

    Can't find any info on this, any takers?


  • 9.  RE: Netsight 6.1 Archive Issue

    Posted 10-31-2014 17:23
    Hi Ian,

    I've only seen that error if the communication to the switch isn't set up properly from the NetSight perspective. One thing to check is that the CLI Credentials are set properly on Profile used to access the switch. If you're using SSH credentials, also make sure that SSH is enabled on the switch.

    -Tyler


  • 10.  RE: Netsight 6.1 Archive Issue

    Posted 11-04-2014 08:28
    Hi Tyler,

    Thanks for the info. This turned out to be the TFTP service on the server had stopped.