ExtremeCloud IQ- Site Engine & Extreme Management Center

  • 1.  netsight upgrade appliance

    Posted 10-08-2014 09:44
    Hello, i'm trying to update my netsight appliance from 5.1.148 to 6.1.0.157. On starting upgrade via CLI i get the following output:

    root@netsight:/tmp$ ./NetSight_Suite_6.1.0.157_64bit_install.bin
    expr: non-integer argument
    Extracting files to /tmp/NetSight_Suite_6.1.0.157_64bit_install_
    chmod: cannot access '/tmp/NetSight_Suite_6.1.0.157_64bit_install_/java': No such file or directory
    chmod: cannot access '/tmp/NetSight_Suite_6.1.0.157_64bit_install_/userpassword': No such file or directory
    ./NetSight_Suite_6.1.0.157_64bit_install.bin: line 298: /tmp/NetSight_Suite_6.1.0.157_64bit_install_/java/jre64/bin/java: No such file or directory

    Same when using the 'silent' option.

    What's wrong here, what i don't see at the moment (blind?)?

    Regards
    Reiner



  • 2.  RE: netsight upgrade appliance

    Posted 10-08-2014 11:37
    Hi,

    did you run
    chmod +x NetSight_Suite_6.1.0.157_64bit_install.bin
    to make the installer executable?

    Thanks
    Kurt


  • 3.  RE: netsight upgrade appliance

    Posted 10-08-2014 11:54
    Hello Kurt,

    yes, i changed permission to 755

    Reiner


  • 4.  RE: netsight upgrade appliance

    Posted 10-08-2014 11:54
    Hi Reiner,

    do you have the chance to create a case with GTAC? I discussed this with our internal NetSight admin and he also can't see anything obvious you are doing wrong here. One thing to check might be the MD5 sum of the downloaded .bin file to see if it has been downloaded properly of whether the file might be corrupt. You could try to re-download and re-copy it to the NetSight appliance.

    The only actions I run on upgrades are
    - copy to /tmp folder (if your NetSight server is REALLY old, there might not be enough space on the /tmp folder so you might have to copy and run it on another share)
    - chmod +x
    - and run the bin using ./NetSight...bin

    Kurt


  • 5.  RE: netsight upgrade appliance

    Posted 10-08-2014 11:54
    Hello Kurt,
    thanks for the hint regarding checksum! There obviously went something wrong at the file transfer. Checksum was different. Now did a new transfer and install is running like hell!

    Regards Reiner


  • 6.  RE: netsight upgrade appliance

    Posted 10-08-2014 11:54
    great to hear - thanks for your feedback