ExtremeSwitching (ERS)

 View Only
Expand all | Collapse all

ERS 4826 GTS-PWR+ | Agent Code Checksum Failed

  Thread closed by the administrator, not accepting new replies.
  • 1.  ERS 4826 GTS-PWR+ | Agent Code Checksum Failed

    Posted 06-02-2021 08:15
    No replies, thread closed.

    One of our customers had their legacy stack’s base unit fail, and I replaced the failed unit with a spare one that they had on site. 

    The “base” switch at the back is on, and the stacking cables in the rear are as they were on the failed unit. 

    I powered the new switch on, and for a moment the auto-unit-replacement system seemed to have worked, until the replacement unit’s first reboot. 

    After that the replacement unit is stuck on the following message: 

    Ethernet Routing Switch 4826GTS-PWR+
    Reading MAC Address...
    MAC Address: <censored>
    Resets:         2.

    Dip Switch in Base Unit position
    RAM   size:    1GB
    FLASH size:   64MB
    Super ISO is present

    Attaching SOC unit 0... PCI device ASIC attached as unit 0 

    Diagnostics   Mar 02 2012, 10:27:37

    Test 106  USB   Register Test             - PASSED
    Test 111  DDRAM Walking 1/0s              - PASSED
    Test 112  DDRAM Byte/Word/Long            - PASSED
    Test 113  DDRAM Power-of-2                - PASSED
    Test 121  ROM   Config                    - PASSED
    Test 151  FANs  Status                    - PASSED
    Test 207  XGS   SWITCH Registers          - PASSED
    Test 221  PHYs  Register                  - PASSED
    Test 271  Ports Internal Loopback         - PASSED

    ## Agent Code Checksum Failed

    Press 'a'  to run Agent code
    Press 'd'  to download agent/diag/bootloader code
    Press 'e'  to display Errors
    Press 'i'  to initialize config flash
    Press 'p'  to run POST tests
    Press 'r'  to reset the box…

    And so I’ve narrowed it down to the SW version mismatch. 

    The remaining 2 out of 3 units in stack are now on: 

    #show boot image
    Unit  Agent Image Active Image
    ----- ----------- ------------


    The replacement unit was still running an ancient; 


    So my further search online revealed this


    So my question was, could I still remedy the situation, or did I write off a perfectly good switch by having the stack push the new SW version on it? Because from what I understood, the upgrade path for 4826 didn’t allow upgrading directly from 5.6.x.x to 5.12.x.x and required several steps in-between. 

    As this was a legit purchase from Avaya, the customer still have access to the original legacy SW versions in their internal DB, back from the day this so;lution was implemented.

    I did find an agent version of  FW:, copied it to the USB, inserted the USB to the switch and on the “Agent Code Checksum Failed” prompt above, pressed “d” to download and implement the .img; 

    Worked like a charm. 

    This was originally a question, but then while I was typing it, the image was being downloaded. It then booted the switch back to its original - factory default state, and instead of just deleting it, I though it may help someone in the future. 

    I understand I may be totally off, as the ERS4800 series is a dinosaur. 

  • 2.  RE: ERS 4826 GTS-PWR+ | Agent Code Checksum Failed

    Posted 06-20-2021 01:01
    No replies, thread closed.

    Good Info. Thanks