Data Center (VDX)

 View Only

VXLAN L2 Extension Configuration question

  • 1.  VXLAN L2 Extension Configuration question

    Posted 12-14-2021 16:02


    Greetings,

    I am tasked by my manager to configure VXLAN in our lab  using  BROCADE VDX6740  and ICX 7750 .We have a couple of VM clients connected to each of these Brocade devices .I  have OSPF configured as an IGP to provide the underlay transport connectivity and i can reach the loopback interfaces of the VXLAN tunnel  endpoints.

    The VXLAN configuration on the ICX requires that the vlans to be mapped to a vni must not have a VE interfaces in the running config .

    ICX7750-1(config-overlay-gw-VXLAN_TO_VDX6740)#map vlan 10 to vni 1001
    error - virtual router interface configured on L2 vlan

    So i removed the ve interface  i had with an ip which servers as the default gateway to the client A . After that i configured the L2 VXLAN Extension on the ICX 7750  as follows :

    overlay-gateway VXLAN_TO_VDX6740
    type layer2-extension
    ip interface loopback 1
    map vlan 10 to vni 1001
    site SITE-A
    ip address 10.20.1.1
    extend vlan add 10

    ICX7750-1#show overlay-gateway

    Overlay Gateway Name : VXLAN_TO_VDX6740
    Type : layer2-extension
    Source IP Interface : loopback 1 (vrf: default-vrf, IP address: 10.10.1.1)
    Total Mapped Vlans : 1
    Total Sites : 1

    Total 1 Overlay Gateways

    CX7750-1#sh overlay-gateway VXLAN_TO_VDX6740 detail

    Overlay Gateway Name : VXLAN_TO_VDX6740
    Type : layer2-extension
    Source IP Interface : loopback 1 (vrf: default-vrf, IP address: 10.10.1.1)
    Total Mapped Vlans : 1
    Total Sites : 1
    # VLAN-ID VN-ID VFI Access-Port Extended-Site
    - ------- ----- --- ----------- -------------
    1 10 1001 10 1 1
    # SiteName IP-Address Status Ext-Vlans
    - -------- ---------- ------ ---------
    1 SITE-A 10.20.1.1 Up (10)
    ICX7750-1#

    ===============================================================

    VXLAN Config on the VDX6740

    overlay-gateway VXLAN_TO_ICX7750
    type layer2-extension
    ip interface loopback 1
    attach rbridge-id add 1
    map vlan 10 vni 1001
    site SITE-B
    ip address 10.10.1.1
    extend vlan add 10
    activate

    rb1# ping 10.10.1.1
    Type Control-c to abort
    PING 10.10.1.1 (10.10.1.1): 56 data bytes
    64 bytes from 10.10.1.1: icmp_seq=0 ttl=58 time=1.238 ms
    64 bytes from 10.10.1.1: icmp_seq=1 ttl=58 time=1.093 ms
    64 bytes from 10.10.1.1: icmp_seq=2 ttl=58 time=1.077 ms
    64 bytes from 10.10.1.1: icmp_seq=3 ttl=58 time=1.213 ms

    rb1# show vlan 10
    VLAN Name State Ports Classification
    (F)-FCoE (u)-Untagged
    (R)-RSPAN (c)-Converged
    (T)-TRANSPARENT (t)-Tagged
    ================ =============== ========================== =============== ====================
    10 VLAN0010  ACTIVE Te 4/2/7(u)
    Te 1/0/1(t)
    Te 1/0/17(u)
    Tu 61441(t) vni 1001

    rb1# show tunnel brief
    Number of tunnels: 1

    Tunnel 61441, mode VXLAN, rbridge-ids 1
    Admin state up, Oper state down
    Source IP 10.20.1.1, Vrf default-vrf
    Destination IP 10.10.1.1



    The tunnel operation is down on the VDX6740.

    I tried generating some icmp traffic from one client towards the other , to see if this will trigger the tunnel to change to  operational , but it did not work and the pings fail .

    I am suspecting the issue might be that client A cannot ping its default gateway ( ICX7750 ) since i had to remove the int ve ip address for vlan 10 on the ICX to avoid the error i was getting when i was configuring vxlan.

    The VDX 6740 can ping the client B and it servers as its DG .

    Yet, if this is just a L2 extension , no default Gateway is needed since both clients belong to the same subnet/broadcast domain.

    i successfully configured L2 extension VXLAN on Arista  devices within GNS3 ans was able to ping b/w the clients without setting a default gateway on the clients  since they do not need it to communicate locally on the same subnet


    Please advise if you had ran through the same issue .

    planning to configure VXLAN using BGP EVPN after i get this one working .

    Thank you in advance

    Talal