Solved

SLX 9740 20.2.3 BGP not running

  • 26 February 2021
  • 4 replies
  • 69 views

Hi

Im facing some problem with BGP on SLX9740

BGP is configured but:

show ip bgp summary all-vrfs  

-----------------------------------------------------------------------
             VRF: default-vrf
-----------------------------------------------------------------------
BGP is not operational

-----------------------------------------------------------------------
             VRF: RKPM01
-----------------------------------------------------------------------
BGP is not operational

-----------------------------------------------------------------------
             VRF: RKGM01
-----------------------------------------------------------------------
BGP is not operational

 

Below configuration for router bgp

show running-config router bgp
router bgp
capability as4-enable
address-family ipv4 unicast
!
address-family ipv4 unicast vrf RKGM01
 local-as 11111
 neighbor 192.168.52.1 remote-as 1111
 neighbor 192.168.52.1 maximum-prefix 999999
 neighbor 192.168.52.1 prefix-list EPIX-no-advert out
 neighbor 192.168.52.1 route-map in KRPM1-BGP-in
 neighbor 192.168.52.1 route-map out KRPM1-BGP-out
 neighbor 192.168.52.1 description KRPM1-BGP
 neighbor 192.168.52.1 next-hop-self
 neighbor 192.168.52.1 remove-private-as
 neighbor 192.168.52.1 soft-reconfiguration inbound
 neighbor 192.168.52.1 update-source 192.168.52.3
!
address-family ipv4 unicast vrf RKPM01
 local-as 11111
!
address-family ipv6 unicast
!
address-family ipv6 unicast vrf RKGM01
!
address-family ipv6 unicast vrf RKPM01
!
address-family l2vpn evpn
!
!

trying to show summary for vrf BGP:

show ip bgp summary vrf RKGM01
BGP is not operational

 

But show ip bgp neigh at vrf

show ip bgp neighbors vrf RKGM01
   Total number of BGP Neighbors: 1
   '+': Data in InQueue '>': Data in OutQueue '-': Clearing
   '*': Update Policy 'c': Group change 'p': Group change Pending
   'r': Restarting 's': Stale '^': Up before Restart '<': EOR waiting

1   IP Address: 192.168.52.1, AS: 1111 (EBGP), RouterID: 0.0.0.0, VRF: RKGM01
      Description: KRPM1-BGP
   State: IDLE, Time: 2h55m2s, KeepAliveTime: 60, HoldTime: 180
   Minimal Route Advertisement Interval: 0 seconds
      UpdateSource: Address 192.168.52.3
      NextHopSelf: yes
      RemovePrivateAs: : yes
      SoftInboundReconfiguration: yes
   Address Family : IPV4 Unicast  
      MaximumPrefixLimit: 999999
      Prefix-list: (out) EPIX-no-advert   
      Route-map: (in) KRPM1-BGP-in  (out) KRPM1-BGP-out   
   Messages:    Open        Update      KeepAlive   Notification   Refresh-Req
      Sent    : 0           0           0           0              0           
      Received: 0           0           0           0              0           
   Last Connection Reset Reason:Unknown
   Notification Sent:     Unspecified
   Notification Received: Unspecified
   Neighbor NLRI Negotiation:
     Peer configured for IPV4 unicast  Routes
   Neighbor ipv6 MPLS Label Capability Negotiation:
   Neighbor AS4 Capability Negotiation:
     Peer configured for AS4  capability
   Outbound Policy Group:
      ID: 1, Use Count: 1
   BFD:Disabled
Error: TCP status not available
   Maintenance Mode : Disabled
   G-Shut: Disabled

 

icon

Best answer by joergkost 26 February 2021, 22:49

→ see down under :grinning:

View original

This topic has been closed for comments

4 replies

Userlevel 3

See above, I just edited it :-), you have been too quick :-)

You need configure a local-as in the router bgp global. 

Userlevel 3

→ see down under :grinning:

shoyes:

vrf RKGM01
address-family ipv4 unicast
 max-route 3000000
!
address-family ipv6 unicast
 max-route 3000000
!
ip router-id 10.10.10.1
!
interface Loopback 1
vrf forwarding RKGM01
ip address 10.10.10.1/32
no shutdown



 

Yes thank You - it was exactly this…

There need to be some changes made in manual :) because I was trying to search some “enable bgp service”

Because for me there will be no BGP normally used in vrf default - that is why I didn’t configured any local-as for that vr - just for other vrf’s

 

Thank You again.