Header Only - DO NOT REMOVE - Extreme Networks

How to add an IP to a VLAN interface? Brocade VDX NOS 6.0x


I've inherited a VDX 6740T and I'm trying to add an IP to a vlan / vlan interface. VLAN has been created and assigned to the appropriate ports as tagged, and I've created a VE interface with matching ID. However, I'm unsure how to add an IP to this.

Anyone familiar with the Brocade VDX NOS?

5 replies

Userlevel 1
Create VLAN
interface vlan 10[/code]Create VE & IP under Rbridge configuration
rbridge-id 1
interface Ve 10
ip address 192.168.1.1/24
!
no shutdown[/code]
VLAN untagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport mode access
switchport access vlan 10
no shutdown[/code]Or VLAN tagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport
switchport mode trunk
switchport trunk allowed vlan add 10
switchport trunk tag native-vlan
no shutdown[/code]
Hope this helps
Mick Day wrote:

Create VLAN
interface vlan 10[/code]Create VE & IP under Rbridge configuration
rbridge-id 1
interface Ve 10
ip address 192.168.1.1/24
!
no shutdown[/code]
VLAN untagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport mode access
switchport access vlan 10
no shutdown[/code]Or VLAN tagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport
switchport mode trunk
switchport trunk allowed vlan add 10
switchport trunk tag native-vlan
no shutdown[/code]
Hope this helps

helps a lot! Can the ports work in some kind of hybrid mode (tagged and untagged)?
Mick Day wrote:

Create VLAN
interface vlan 10[/code]Create VE & IP under Rbridge configuration
rbridge-id 1
interface Ve 10
ip address 192.168.1.1/24
!
no shutdown[/code]
VLAN untagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport mode access
switchport access vlan 10
no shutdown[/code]Or VLAN tagged on interface
interface TenGigabitEthernet 1/0/1
switchport
switchport
switchport mode trunk
switchport trunk allowed vlan add 10
switchport trunk tag native-vlan
no shutdown[/code]
Hope this helps

Same thing but for > 7.2.0a1 please?
Userlevel 1
VDX does not have a dual mode as such

If you set native VLAN as untagged this may acheive the desired outcome
interface TenGigabitEthernet 1/0/1
switchport trunk tag native-vlan See http://www.brocade.com/content/html/en/configuration-guide/nos-700-l2guide/GUID-73EDD343-D4CB-4990-AB97-C6C0C7E40C15.html[/code]
Userlevel 1
VDX does not have a dual mode as such

If you set native VLAN as untagged this may acheive the desired outcome
interface TenGigabitEthernet 1/0/1
no switchport trunk tag native-vlan [/code]See http://www.brocade.com/content/html/en/configuration-guide/nos-700-l2guide/GUID-73EDD343-D4CB-4990-AB97-C6C0C7E40C15.html
Does this switch support Voice Traffic.

Reply