Header Only - DO NOT REMOVE - Extreme Networks

SLX 9140 ip-address on layer 3 port-channel


Hello. I tried ro make port-channel as L3 interface but can't assign ip-address on it and have no success. Please help.
TESTWASH(config-Port-channel-30)# do sh run int e 0/1[/code]interface Ethernet 0/1[/code] channel-group 30 mode active type standard[/code] lacp timeout long[/code] no shutdown[/code]![/code]TESTWASH(config-Port-channel-30)#[/code]TESTWASH(config-Port-channel-30)# do sh run int po 30[/code]interface Port-channel 30[/code] no shutdown[/code]![/code]TESTWASH(config-Port-channel-30)#[/code]TESTWASH(config-Port-channel-30)# no switchport[/code]TESTWASH(config-Port-channel-30)# ip add[/code] ^[/code]% Invalid input detected at '^' marker.[/code]TESTWASH(config-Port-channel-30)# ip ?[/code]Possible completions:[/code] access-group Configure IP Access group[/code] arp Configure Arp Inspection[/code]

4 replies

Hi Mikhail,

i think you need to do it with a Ve .

Configuring
VE route-only mode on a LAG port
Do the following to
configure
VE route-only mode on a LAG (port-channel) port.
1. Enter global
configuration
mode.
device# configure terminal
2. Create a VLAN.
device(config)# vlan 100
3. Specify a port-channel interface.
device# configure terminal
device(config)# interface port-channel 1
4. Enter the
switchport
command to
configure
Layer 2 characteristics.
device(config-Port-channel-1)# switchport
5. Specify trunk mode.
device(config-Port-channel-1)# switchport mode trunk
6. Tag the port to a VLAN.
device(config-Port-channel-1)# switchport trunk allowed vlan add 100
7. Enable tagging on native VLAN
traffic.
device(config-Port-channel-1)# switchport trunk tag native-vlan
8. Enter the
route-only
command top enable Layer 3 routing exclusively on the port.
device(config-Port-channel-1)# route-only
Use the
no route-only
command to revert to default Layer 2 and Layer 3 behavior.
9. Enable the interface and exit to global
configuration
mode.
device(config-Port-channel-1)# no shutdown
device(config-Port-channel-1)# exit
10. Verify the port-channel
configuration.
device(config-Port-channel-1)# do show running-cocnfig interface port-channel 1
interface Port-channel 1
switchport
switchport mode trunk
switchport trunk allowed vlan add 100,200
switchport trunk tag native-vlan
route-only
no shutdown
11. Enter virtual Ethernet (VE)
configuration
mode and specify the VLAN.
device(config)# interface ve 100
12. Assign an IP address and mask and enable the interface.
device(config-Ve-100)# ip address 10.2.2.2/24
device(config-Ve-100)# no shutdown
13. Verify the VE
configuration.
device(config-Ve-100)# )# do show running interface ve 100
interface Ve 100
ip proxy-arp
ip address 10.2.2.2/24
no shutdown
Hello Michael Dinius,
Thank you for answer.
Unfortunately i have no such command:

interface Port-channel 30[/code] switchport[/code] switchport mode trunk[/code] switchport trunk allowed vlan add 10[/code] switchport trunk tag native-vlan[/code] no shutdown[/code]![/code]TESTWASH(config-Port-channel-30)# r?[/code] ^[/code]% Invalid input detected at '^' marker.[/code]TESTWASH(config-Port-channel-30)# ?[/code]Possible completions:[/code] cee Apply default CEE map 'default'[/code] describe Display transparent command information[/code] description Interface specific description[/code] do Run an operational-mode command[/code] exit Exit from current mode[/code] help Provide help information[/code] ip The Internet Protocol (IP).[/code] ipv6 The Internet Protocol version 6(IPv6).[/code] logical-interface Configure a Logical Interface on port-channel[/code] mac Configure MAC parameters[/code] minimum-links Least number of operationally UP links to declare port-channel UP[/code] mtu Set mtu value to interface[/code] no Negate a command or set its defaults[/code] priority-tag Configure 802.1p priority tagging[/code] protocol Protocol configuration[/code] pwd Display current mode path[/code] qos Quality of Service (QoS)[/code] service-policy Attach Input/Output Policy Map[/code] shutdown Shutdown the selected interface[/code] spanning-tree Spanning tree commands[/code] speed Set speed informational parameter[/code] switchport Set the switching characteristics of the Layer2 interface[/code] system System settings[/code] top Exit to top level and optionally run command[/code]TESTWASH(config-Port-channel-30)#[/code]
Below is output show version, may be i have wrong firmware?

TESTWASH# show version[/code]
SLX-OS Operating System Software[/code]SLX-OS Operating System Version: 17s.1.00[/code]Copyright (c) 1995-2018 Brocade Communications Systems, Inc.[/code]Firmware name: 17s.1.00a[/code]Build Time: 02:29:08 Apr 1, 2017[/code]Install Time: 22:39:26 Jun 23, 2017[/code]Kernel: 2.6.34.6[/code]Host Version: Ubuntu 14.04 LTS[/code]Host Kernel: Linux 3.14.17[/code]
Control Processor: QEMU Virtual CPU version 2.0.0[/code]
System Uptime: 0days 0hrs 15mins 48secs[/code]
Slot Name Primary/Secondary Versions Status[/code]---------------------------------------------------------------------------[/code]SW/0 SLX-OS 17s.1.00a ACTIVE*[/code] 17s.1.00a[/code]
OK i see .
Route only is not possible on this.
So please see this example for vlan 100
vlan 100
router-interface Ve 100

interface Ve 100
ip address 1.1.1.1/24
no shutdown

interface Ethernet 0/9
channel-group 100 mode active type standard
lacp timeout long
no shutdown

interface Port-channel 100
switchport
switchport mode trunk
switchport trunk allowed vlan add 100
switchport trunk tag native-vlan
shutdown
!

you can not have a ip address direct on a LACP interface only via VE and a Vlan added to the Port channel
Thank you for answer. I wanted to try L3 ip-adress directly on port-channel without using VLANs, probably it is impossible on SLX 9140

Reply