Question

ExtremeCloud IQ Config update issue

  • 23 March 2020
  • 4 replies
  • 1272 views

Userlevel 4
  • Extreme Hero
  • 140 replies

Hi Guys,

 

I hope everyone is healthy and safe!

 

I'm getting an error while trying to update my APs config (Delta Update) from ExtremeCloud IQ:

 

The CLI 'clock time-zone daylight-saving-time null null null null' execute failed, cause by: Unknown error

 

I forced an Complete Config update (which includes a reboot), and it completed without issues, but, obviously we can't reboot APs at each config change…

 

Any ideas?

Best regards and stay safe!

 

-Leo


4 replies

Userlevel 7

Hi Leo,

 

could you share the AP CLI output for #show ntp ?

 

-Ron

Userlevel 4

Hi Leo,

 

The last 4 null’s are interesting, normally it should show start date & time and end date & time of the DST period. Going off the URL in your email signature you’re in Brazil, which upon googling does not use DST any longer?

I presume that the AP needs a complete update to remove the command from itself, hence why it’s failing with the delta.

Does the AP that you pushed a complete to accept delta changes (i.e. changing the hostname) now?

Userlevel 4

UPDATE: I'm running a few more tests after writing this post… I'll update with any findings later, but below are some info of what I got until now.

 

Hi guys,

Sorry about the late response.

I've deployed a LAB VGVA Gateway and the issue is the same...

@Ronald Dvorak , follows a screenshot of the show NTP from a VGVA (same on APs):

 

 

@Ash Finch Sure, I'm from Brazil and since the end of 2019 we don't have DST anymore…

I've already issued an "Complete Update" on the APs (running since last october) and on the today-deployed VGVA… This is the ONLY way to apply any config, BUT it enforces an reboot, what is undesired on a production environment.

Using a DELTA update, the issue is the same:

 

It looks like the XIQ try to apply in the background the cli command "clock time-zone daylight-time-saving" with NULL parameters, which is not expected by VGVA or APs (looks like a bug)…

 

 

Best regards,

 -Leo

Userlevel 4

Hi Guys,

Updating some info:

After a "Complete Update", taking a look at the "show config current"look what I got:

 

Issuing a new "Delta Update", I got the same error:

I tried to issue the CLI commands "no clock time-zone daylight-saving-time" and "save config". Taking a look at the "show config current" and the "clock time-zone daylight-saving-time null null null null" is gone :

After issuing a new "Delta Update", I got the very same error…

 

Looks like the XIQ is trying to apply the command "clock time-zone daylight-saving-time null null null null" which is not right…

 

As I told before, a "Complete Update" works fine, besides of the reboot, but it writes the problematic command in the config…

 

It looks like a BUG in XIQ.

 

Best regards,

 

-Leo

Reply