1 member of stack old xos

  • 0
  • 1
  • Question
  • Updated 5 years ago
Create Date: Sep 28 2012 7:51PM

hi.

going live with a stack this evening. and switch 4 has failed due to incompatible xos version.  

i had actually already set the stack up, i was sure i tested each stack member ... okay.  (is it possible to do with ssh module?)

limited time to do this in tomorrow what is the quickest?

disable-stacking on master
update firmware on switch 4
enable stacking on master

will i lose my config? not a hudge deal, i presume i can just scp into the switch and save the config and put it back afterwards?


i presume i do have to disable stacking, cause i can't even login using the safe admin account as it doesn't see the AAA authentication from the master.


(sorry if it doesn't make sense, v.tired v.noisy machine room) 
 

(from conrad_jones)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 28 2012 10:53PM

Hey Oxide54What I would try is to configure the stack redundancy to full. This will allow any switch in the stack to be master if the master goes away. Disconnect the switch that is at an old version from the stack. At this point it should become a master by itself. Then give an IP address and download the code. Reboot without saving so the ip is gone and when it comes back up add it to the stack.If it doesn't join the stack use the command config stacking node slot x. I think that is the command may need to tab though the command I case I am wrong.Let us know if that works.P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 29 2012 8:45PM

worked a treat prusso.

just did
configure stacking redundancy maximal 

power off stack 
removed stacking cables from unit 4, booted it and the top led started flashing which was a good sign.
logged in and updated the xos and xmod for ssh.

powered off, connected back the stacking cable and powered on.

thank you,

(from conrad_jones)

This conversation is no longer open for comments or replies.