Active IP VLANS & Routing Oh My...

  • 0
  • 1
  • Question
  • Updated 4 years ago
I have a question in regards to the VR-Default and active IP4 VLANS.  I created two new VLAN's according to the documentation and assigned them IP's but they show up as inactive.  What am I missing.   I would just like to route traffic between the VLAN's.  Sorry I am new to the ExtremeOS world.  Here is the show for the VR and one of the new VLAN's I created as well as the show iproute.  The two new VLAN's are Wireless and Desktop.

I am new to ExtremeOS and am trying to wrap my head around it.

Thanks in advance. 


Virtual Router        : VR-Default                Type : System
Description           : Default VR
Operational State     : Up
IPv4 Admin State      : Enabled     IPv6 Admin State   : Enabled
IPv4 Route Sharing    : Disabled    IPv6 Route Sharing : Disabled
Protocols Configured  :
--------------------------------------------------------------------
Protocol    Process       Configuration    Protocol
Name        Name          Module Name      Instances
--------------------------------------------------------------------
RIP         rip           rip                      1
RIPng       ripng         ripng                    1
--------------------------------------------------------------------
Port List             : 1-50
VLANS                 : Default, VoiceVLAN, Data,
                        Wireless, Desktop
Virtual Router Totals :
Total Protocols       :     2    Max Protocols         :     8
Total Ports           :    50
Total Vlans           :     5
Total IPv4 Vlans      :     4    Total Ipv6 Vlans      :     0
Active IPv4 Vlans     :     2    Active Ipv6 Vlans     :     0
Inactive IPv4 Vlans   :     2    Inactive Ipv6 Vlans   :     0

 sh iproute
Ori  Destination        Gateway         Mtr  Flags         VLAN       Duration
#d   192.168.10.0/24    192.168.10.253  1    U------um--f- Data       691d:4h:59m:20s
#d   192.168.20.0/24    192.168.20.253  1    U------um--f- VoiceVLAN  1138d:4h:39m:59s
 d   192.168.30.0/24    192.168.30.254  1    -------um---- Wireless   1d:1h:5m:5s
 d   192.168.40.0/24    192.168.40.254  1    -------um---- Desktop    1d:1h:4m:30s
Photo of Brian

Brian

  • 80 Points 75 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 0
  • 1
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Make sure that you have added the port in VLANs and at least one of the port should be in active state to activate the vlan.

You also need to enable ipforwarding on communicate between two vlans.
Photo of CEFLOU

CEFLOU

  • 190 Points 100 badge 2x thumb
Hi brian, y Just activate ipforwading and put each port in the right vlan. If y dont connect any think on port based vlan y never have the vlan interface up ;) i'm new in extreme too
Photo of Brian

Brian

  • 80 Points 75 badge 2x thumb
Thanks all.  I also figured out if i enabled the loopback it shows up and actually responds to a ping :) 
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,676 Points 10k badge 2x thumb
Hi, yes the purpose of a loopback interface is to keep your vlan interface always Up. It can be a good thing, but can also turn out to be a bad idea, depending on the topology and use case. If your router is keeping advertising the route to a resource it can't reach anymore, that's not necessarily a good idea.

As correctly stated previously, for your vlan interface to be Up, you need at least one active port in it, and enable ipforwarding for that vlan as well. Then routing can happen with other vlans with ipforwarding also enabled. This is also a prerequisite to configure any dynamic routing protocol, like OSPF.