Added unused/new switch to stack now I get pending-aaa on console port

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
I added another x440-48p to my existing stack. I did not set up the existing stack. I enabled and synched the new node, but I get the "pending-aaa" prompt on the console port. Rebooting did not help.  As I recall the only difference in the switch's was the bootrom the new switch had 2.0.1.7 while the old nodes are running 2.0.1.6.  I was under the impression this was not an issue, they all have EXOS 15 in particuler if memory serves me right all 3 have 15.2.2.7.  Show version shows N/A for the new slot (slot 3). Do I need to remove and reset the new slot and downgrade the bootrom?  Show stacking details only returns info on the first 2 nodes not node 3.
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
1) Disconnect the stacking cable from the switch which is stuck on pending-AAA

2)Power cycle the switch which is stuck on pending-AAA and go into the bootrom. To go in bootrom, you have to press spacebar while booting.

3)Execute the commnad "config none" and "reboot as MASTER-CAPABLE".

4) The switch will boot normally. 

5) To build stack, software version and license should exactly match with existing slot module which are in stack.

Let me know if have any doubt on this.
 
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb
OK thanks.  So I need to downgrade my bootrom to 2.0.1.6, and upgrade my image.  Turns out the switch I add was on 15.2.1.5, would have sworn it was on 15.2.2.7.   Also does the diagnostics ver have to be the same? My license is good. I would have sworn the only issue was bootrom.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
 if node's master capability is off and there is no connection between the current master switch and this switch then we can see pending-aaa. This is the one of the strong reason for showing pending-AAA. you have to just follow the step which I have mentioned in above post to overcome this issue. Once the switch boot normally, check the license and software version....Bootrom can be different among the slots, but it is better to have same bootrom on the  summit slot which are being part of stack.
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb
This will be the first time I have change the software versions on an extreme. So after I get the software version sorted out your saying leave the new nodes  "master capable" option on? But I can leave the role as none correct?
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
There are three noderoles: master (or primary), backup, and standby. It should not be none in stacking.

it is recommended to have master-capability on, this will help when the master switch goes down, backup will becomes master and the other standby node which has master-capability on will becomes backup. 

it is always recommended to have latest & stable software to be install on switch. For X440 stack, I would like to recommend to have EXOS 15.3.1.4 patch 1-31 software installed.

You can download the software from esupport.extremenetworks,com.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
All the issue regarding pending-aaa is mentioned in EXOS 15.4 concept guide page # 189.
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb
OK so I finally got the switch updated and inline with the others. But if I synch the new node with the others it resets the master capable. I suspect I need to tweak a config on the stack to allow it to be master capable role, see as the synch kills that functions. 
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb
All is well now.  I had to upconfig the switch, update the primary image, thus making both prim and sec match the stack.  After that was good to go, I then enabled stacking (without the easy config), enhanced protocol, master capable saved, removed power.  Then I add it to the stack, powered it up, the master stack recognized but I needed to config a slot number and Stack MAC, it also appeared to do some sort of auto synch on its own,  rebooted switch overnight and everything is good to go.  I think I will avoid the synch command in the future, as it seemed to bork the new switch every time I ran it.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
which command did you use, only "synchronize" or "synchronize stacking {node-address <node-address> | slot <slot-number>}"?
Photo of Joe

Joe

  • 430 Points 250 badge 2x thumb
synchronize stacking slot 3