Android Phones are losing WLAN connectivity after several minutes

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
EWC V9.21.12 - WLAN running now stable for laptops! Except Android SmartPhones have problems anymore!

If the Smartphone is newly connected all working well - also if i ping the system continiously - no problems. If i stop the ping, then after some time the client have no internet connection - wlan seem to be assiciated. If i disassociate (both sides) and re-connect this device new all working well for several time (minutes). If i restart the AP also all working well for some time. So allways if a smartPhone client is online for more than a few minutes the problem begins (looses IP / Internet Connectivity).

only 2,4Ghz is online, no channel bundeling (20Mhz Channels), no special options set.

After some debugging (wireshark capture) i see that if the clients are not working, the smartphones are sending a lot of "Qos Null function (No data)" packets. If i ask Mr. Google he tell me that this packets managing powersafe modus. Thats correct - wireshark tells in one packet (of the problematic clients) "STA will go to sleep" - next packets tells "STA will stay up" ?! And this toggle several times a second!

So how can i avoid this ?

i cannot disable powersafe mode on clients because i have no access to them. Because this is payed WLAN service we have to provide a working service (without have the ability to tough client systems) and without disruption and re-connects.

How can i solve that problem ?
Photo of M.Nees

M.Nees, Embassador

  • 9,588 Points 5k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,004 Points 50k badge 2x thumb
So the client report show everything is OK in that state ?
Correct role, SSID, PVID and authenticated.
Photo of M.Nees

M.Nees, Embassador

  • 9,588 Points 5k badge 2x thumb
Hi Ronald,

Client report show all fine - RSS, Role, Status, etc.

Regards
Photo of Sai Prasad Rao Rapolu

Sai Prasad Rao Rapolu

  • 1,494 Points 1k badge 2x thumb
Is there power save option enable/disable on Access Point radio's.  I can see some "Optimized for power save" option on radios.
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,004 Points 50k badge 2x thumb
I normally only enable WMM & 802.11e and leave U-APSD off.
Photo of Ostrovsky, Yury

Ostrovsky, Yury, Employee

  • 3,050 Points 3k badge 2x thumb
Try to disable Management Frame Protection (on VNS-->WLAN service -->Privacy) , we have seen devices having such issue if its enabled . 
Photo of Sai Prasad Rao Rapolu

Sai Prasad Rao Rapolu

  • 1,494 Points 1k badge 2x thumb
Hi Ostrovsky



Above option is only available for secured WLAN Service (WPA/WPA2 etc), what about open WLAN Service ?   
Photo of Ostrovsky, Yury

Ostrovsky, Yury, Employee

  • 3,050 Points 3k badge 2x thumb
Correct , the MFP is only a feature of secured WLAN . 
Optimize for PS will not help , this feature affects only multicast traffic . 
Btw , what sort of Android phones you are talking about - is there a particular model , or just any Android having this issue?
How about 5Ghz radio - do you see the same issues there? Or only 2.4/open SSID/9.21/<AP type?>
Photo of Sai Prasad Rao Rapolu

Sai Prasad Rao Rapolu

  • 1,494 Points 1k badge 2x thumb
Most of the Mobile's are apple and htc , issues are with both radios.


Users are jumping between radios on same ap very frequently every few minutes.
(Edited)
Photo of Ostrovsky, Yury

Ostrovsky, Yury, Employee

  • 3,050 Points 3k badge 2x thumb
Jumping between radios on the same AP is not what you want to see when network is properly functioning. I would suggest to contact GTAC for sure so they can take a look the config and itroubleshoot.
Photo of M.Nees

M.Nees, Embassador

  • 9,588 Points 5k badge 2x thumb
I looking for some KB Artikels regarding current WLAN Performance Issues or WLAN Config Best Practises.

Also EWC manual (user guide - Advanced Settings of AP / VNS / etc) and Extreme Solution Guide give some interessting hints regarding recommended WLAN settings.

After that changes Client Connection seem to be better and more stable. But futher investigations are have to be done to be sure that all working well.

Regards
Photo of Sai Prasad Rao Rapolu

Sai Prasad Rao Rapolu

  • 1,494 Points 1k badge 2x thumb
Hi Matthias



What changes are you taking about, can you please let me know it will be useful to me ......