Any way to adjust MESH roaming time?

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
Hi,
Setup is RFS4000 + 4x AP6522 + 2x AP6522 setup as client bridges on vehicles.
I am noticing that roaming is taking about 4 seconds to complete when the vehicles move from one AP to the next (speed is slow, approx. 5 Km/h).  The roaming duration is causing the client application to fail because the data stream is cut-off for 4 seconds while the roam is taking place.  The applications is PLC traffic.
The wireless radios are using 5GHz non-DFS channels.
Signal levels are good, typically around -62 to -57dBm at the vehicle.

Is there any way to make the roaming process go quicker ?  

I'm seeing this in the logs during roaming, it seems process is taking 3 seconds from start to finish according to the logs, but I'm seeing about 4 seconds of data loss in total.

Is the radio actually turning off and back on again during the roam?  
2017-10-06 12:05:07     TV01  MESH       MESHPOINT_ROOT_CHANGE Meshpoint 'BRIDGE' root changed from B4-C7-99-E7-B6-C2 to B4-C7-99-E9-17-42 via next hop B4-C7-99-E9-17-42
2017-10-06 12:05:04     TV01  DIAG       NEW_LED_STATE        LED state message RADIO_2_52G_LED_ON from module DOT11
2017-10-06 12:05:04     TV01  RADIO      RADIO_STATE_CHANGE   Radio 'TV01:R2' changing state from 'Initializing' to 'On' 
2017-10-06 12:05:04     TV01  DIAG       NEW_LED_STATE        LED state message RADIO_2_52G_LED_ON from module DOT11
2017-10-06 12:05:04     TV01  RADIO      RADIO_STATE_CHANGE   Radio 'TV01:R2' changing state from 'On' to 'Initializing' 

Relevant configs:
meshpoint BRIDGE
 description Bridge mesh for vehicles
 meshid BRIDGE
 beacon-format mesh-point
 control-vlan 61
 allowed-vlans 1,60-61
 security-mode psk
 wpa2 psk 0 xxxxxxxxxxxxxxxxxxxxxxxxx
 no root
...
profile ap6522 AP-Bridge
...
 interface radio2
  meshpoint BRIDGE bss 3
...
meshpoint-device BRIDGE
  root
  monitor critical-resource action no-root
  monitor primary-port-link action no-root
  exclude wired-peer mint-level-1
  acs channel-width 5GHz 20MHz
... profile ap6522 AP-TV
...
 interface radio2
  meshpoint BRIDGE bss 3
...
meshpoint-device BRIDGE
  no root
  path-method mobile-snr-leaf
  acs channel-width 5GHz 20MHz
 service meshpoint loop-prevention-port ge1
The only device overrides on the APs are "no ip igmp snooping".

Thanks!
Photo of Andrew Webster

Andrew Webster

  • 1,878 Points 1k badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Alona

Alona, Employee

  • 1,700 Points 1k badge 2x thumb
Did you configure channel-list under rf-domain? This is the channes ACS is going to use. If you know where you root Aps are - those are the channels that needed to be in that list and less channels - the better. Also you are trying to configure VMM here - not bridge. Some settings are missing like "rts-threshold 1" and rate selection needs to be opportunistic.

This AP also supports another feature - bridge without using MCX. Instead of configuring VMM - you configure just rf-mode bridge and define channels for bridge to search on. You won't need roots in this case as well. Roaming will be faster.
Photo of Alona

Alona, Employee

  • 1,700 Points 1k badge 2x thumb
Correction - since you are using AP 6522 - VMM on AP 6522 is not supported. SO what you have conifgured won't work at all.
The only think you can use if actual bridge functionality as I described. Meshpoint won't work for you at all as mobile-snr-leaf is not supported on AP 6522.
Photo of Timo

Timo

  • 3,210 Points 3k badge 2x thumb
Maybe you should exchange the APs again a client bridge. We always use client bridges instead of APs as client bridge. Works perfect.
Photo of Phil storey

Phil storey

  • 1,254 Points 1k badge 2x thumb
AP7532 - work well as a bridge
Photo of Andrew Webster

Andrew Webster

  • 1,878 Points 1k badge 2x thumb
Thanks for all the suggestions.
rf-domain does have "channel-list 5GHz 36,40,44,48,149,153,157,161"

The system has been operating since early 2014, so the 6522 was the best fit at that time, and the roaming issue may or may not have been present since the beginning, but only now the application is affected.
Photo of Alona

Alona, Employee

  • 1,700 Points 1k badge 2x thumb
Again - what you have configured - is not supported. You need to use a different features.