AP 3825i on Cisco 3560 Switch

  • 1
  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
I have the folowing problem:
An AP 3825i (V9.21.02)  ist connected witch a LACP Port Channel on a Cisco 3560 Switch

After Switch reboot the AP is not coming up, because the POE recognition is faulty. On the Switch I see no POE Device.

When I disable one of the swichport, the AP becomes a POE Power  immediately. When the AP is up and I enabe the second Port the LACP Channel goes up an everything is o.k. 

It is always no problem when I disable the POE on one Port of the Channel.

Is anyone aware of the problem ?

here the config of the switch :

interface FastEthernet0/2
description AP-test
switchport mode access
channel-group 20 mode active
spanning-tree portfast

interface FastEthernet0/4
switchport mode access
channel-group 20 mode active
spanning-tree portfast

interface Port-channel20
description AP-test
switchport mode access

After Switch reboot:

Switch#show power inline
Available:370.0(w) Used:0.0(w) Remaining:370.0(w)

Interface Admin Oper Power Device Class Max
(Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Fa0/1 auto off 0.0 n/a n/a 15.4
Fa0/2 auto off 0.0 n/a n/a 15.4
Fa0/3 auto off 0.0 n/a n/a 15.4
Fa0/4 auto off 0.0 n/a n/a 15.4

after Disable/enabe fa/0/4

00:11:00: %ILPOWER-7-DETECT: Interface Fa0/2: Power Device detected: IEEE PD
00:11:05: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:11:05: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
00:11:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
00:11:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed sFa0/20 auto off 0.0 n/a n/a 15.4

Switch#
00:11:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
00:11:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
00:11:24: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
00:11:24: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
00:11:26: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
00:11:26: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
Switch#
00:11:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
00:11:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up

 

Switch#show power inline
Available:370.0(w) Used:15.4(w) Remaining:354.6(w)

Interface Admin Oper Power Device Class Max
(Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Fa0/1 auto off 0.0 n/a n/a 15.4
Fa0/2 auto on 15.4 Ieee PD 4 15.4
Fa0/3 auto off 0.0 n/a n/a 15.4
Fa0/4 auto off 0.0 n/a n/a 15.4


Switch#show lacp counters
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
---------------------------------------------------------------------
Channel group: 20
Fa0/2 167 7 0 0 0 0 0
Fa0/4 168 8 0 0 0 0 0

Switch#show lacp int
Switch#show lacp internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 20
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/2 SA bndl 32768 0x14 0x14 0x4 0x3D
Fa0/4 SA bndl 32768 0x14 0x14 0x6 0x3D
Switch#show lacp neigh
Switch#show lacp neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 20 neighbors

Partner's information:

LACP port Oper Port Port
Port Flags Priority Dev ID Age Key Number State
Fa0/2 FA 255 d884.6630.450a 22s 0x9 0x1 0x3F
Fa0/4 FA 255 d884.6630.450a 22s 0x9 0x2 0x3F
Switch#show lacp sys
Switch#show lacp sys-id
32768, 001a.6d6f.5080
Switch#

Photo of Juergen Greza

Juergen Greza

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
  • 1
Photo of Joseph Burnsworth

Joseph Burnsworth

  • 2,328 Points 2k badge 2x thumb
Have you tried turning off CDP on those switch ports?

Also, have you tried a static LAG to the AP?
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,710 Points 20k badge 2x thumb
I would suggest trying the static lag route first, please let us know if that does not work. I would also suggest opening a ticket with GTAC for further review. 
Photo of Juergen Greza

Juergen Greza

  • 110 Points 100 badge 2x thumb
Thank you for your feedback.
This is not a cdp or lag problem !!!
I configured the switch with static lag and cdp off. This is always the same.
This is a problem witch the POE Power detection.
When I connect the ports successively all is good.The first connected Port is the POE Port.
After a switch restart the switch ports starts simultaneously, then the AP has a problem with the Power detection.
I open a ticket with GTAC . The ticket has been closed, because on extreme Switch everything is all right. Cisco TAC says it is a Problem with the AP ?

I'm thankful for every tip.
Photo of Joseph Burnsworth

Joseph Burnsworth

  • 2,328 Points 2k badge 2x thumb
Are you able to change the POE settings on your Cisco switch? Can you choose 802.3af or 802.3at?

If you can make that choice, I would change it and see if it makes a difference for you.
Photo of Juergen Greza

Juergen Greza

  • 110 Points 100 badge 2x thumb
I`ve just tried it with a Netgear Switch, here the problem occurs also.
On an SSA Switch anything is o.k.
Is here any difference about the standard POE protocol ??
Photo of Joseph Burnsworth

Joseph Burnsworth

  • 2,328 Points 2k badge 2x thumb
How many AP's are on this switch? is every AP doing the same thing or just this one? Can you post the complete results of "show inline power" also if you can do a "show ver"

This switch only has 370W available to power the switch and POE. Also, if I recall correctly, The AP will only power from one port at a time, not both.