Applying EOS Licensing to the K-Series

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Article ID: 15004

Products
K-Series
K-EOS-L3
K-EOS-PPC
K-EOS-VSB 

Symptoms
Error: Unknown: "<command>"
Error: Unknown: "<long string ending with ==>" 
Error: Failed to set this license key. 

Cause
In order to obtain the Activation Key to be configured as demonstrated below, it is first necessary to redeem and activate the purchased (or eval) license entitlement in "Enterasys Licensing" (10833). 

License applicability and configuration varies, depending upon the specific license part number. 

K-EOS-L3 

Supported with all firmware releases, this is an Advanced Routing license for enabling OSPF/OSPFv3, PIM-SM/PIM-SSM, and VRF.
Command format: set license advanced "<Activation Key>"

K6(su)->set license advanced "0001:K-EOS-L3:1:4eb2b0a2:0:Demonstration Company:0:8d86164d:u+R6HkHuFZtoZEhdx/jphxlAOPzmqX+ba5Mc2UqWi47Y0hplBrxjt/D9aeIam3utwlYJ4/I/n5dRE86r8ehEGw=="
K6(su)->

The license is applied transparently with no system disruption, and is immediately active ('show license'). 

K-EOS-PPC 

Supported with all firmware releases, this is a User license for increasing the authenticated users-per-port. 
See release notes applicable to your firmware version, for the exact design limits applied to the multiauth command set both with and without this license. 
Command format: set license port-capacity "<Activation Key>"

K6(su)->set license port-capacity "0001:K-EOS-PPC:1:4d08cb17:0:Demonstration Company:0:8d86264s:d36nTYbp8JXDbJDH67HF+dvtsJjrUmiunLMxY3tsfJ8SIq7o0TZfwfJt/wbotIy5SLNVodo3R/YGFWAARDnV6U=="
K6(su)->

The license is applied transparently with no system disruption, and is immediately active ('show license').

K-EOS-VSB

Supported with firmware 8.21.02.0001 and higher, this is a Virtual Switch Bonding license for enabling VSB.
A chassis may be bonded to a like chassis (K6<->K6, K10<->K10) only.
Two licenses are required, to bond the Chassis 1 and Chassis 2 peers.
Command format: set license vsb "<Activation Key>" chassis x

K6(su)->set license vsb "0001:K-EOS-VSB:1:56d57adc:0:Demonstration Company:0:8d86714d:hOy0ZUEoTGP13IqnlnoytWo20CaafpYTzHsjyGyVYT82JdCkvOJcU+RglOQ5i86vdxLUjI+LxClH+Q0g/zp3cA==" chassis 1
K6(su)->

The license is applied transparently with no system disruption, and is immediately active ('show license').  

* Error messages * 

Here are a few of the more common reasons for license-related error messages: 
  • Error: Unknown: "<command>
    Reason: The system does not understand the issued CLI-based command. This may be due to an entry error, but may also be due to the absence of a license required to activate that particular command set. For example; use of OSPF/OSPFv3, PIM-SM/PIM-SSM, and VRF require a K-EOS-L3.
    Resolution: Either enter the command correctly, or first apply the necessary license.
  • Error: Unknown: "<long string ending with ==>"
    Reason: The company name embedded into the Activation Key during the license activation process contains at least one space character, and when issuing the 'set license...' command the user omitted the double-quotes necessary to delimit the entire Activation Key.
    Resolution: Bracket the entire Activation Key string with double-quotes, as shown in all the examples above.
  • Error: Failed to set this license key.
    Reason 1: The Activation Key portion of the 'set license...' command was incorrectly entered, possibly because it is being manually typed (rather than copied-and-pasted) and contains characters (e.g. "0" vs "O", "1" vs "I", "5" vs "S", "8" vs "B") that are easily mistaken for each other.
    Resolution 1: Identify the source of the problem and correct the command entry.
    Reason 2: The company name embedded into the Activation Key during the license activation process contains "special" characters; that is, other than a-z, A-Z, and 0-9 with punctuation (dash and quote characters formatted by a word processor are also considered to be a "special" characters) - and is now being rejected by the 'set license...' command.
    Resolution 2: The license will probably need to be re-Activated. Please send an email to licensing@enterasys.com, reporting the problem; and include both the Entitlement ID and a capture of the problematic command with error message.
    Reason 3:The wrong license is being used for the product. For example, an S-EOS-PPC license is being used instead of a K-EOS-PPC.
    Resolution 3: Confirm that the license is correct for the product.

Solution

FAD (Functions as Designed). 

Please contact the GTAC for further assistance, as necessary.
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